"A disk read error occured" when downloading an image



  • I’ve only run into this on one image, but it happens when uploading from multiple hosts. I’ll upload the image, then download it to another and it’ll say “a disk read error occurred”. This happens when I’m downloading to either a host of the same hardware or a virtual box.

    Edit: I also find it noteworthy that when downloading to a physical host instead of a virtual one, I get video corruption after the download. As in, there’s oddly colored random characters placed in various places around the screen.



  • @Wayne-Workman

    I’m trying to convert our environment to fog, and one of the labs is using software that I really don’t want to figure out how to redo from scratch, so I took one of the computers that was running in there and sysprepped it to audit mode and that’s what this is.



  • @Wayne-Workman said:

    @nengelhardt
    Is this a “from scratch” image, or is it a manufacturer’s image?



  • @Tom-Elliott @Wayne-Workman

    I reuploaded the image using multiple partition, single disk and got the same thing when downloading it to a virtual machine. I have also tried cloning the source host’s drive to a different host’s hard drive using a clonezilla live CD and both disks in the same machine, then uploaded from the hard drive I cloned to and got the same error after download, but not when I tried to boot the hard drive I cloned to locally.


  • Senior Developer

    The odd colors are most likely due to it being partimage. This isn’t what’s hurting the image as a whole.

    The disk read error occured is coming from your server or the hosts disk?

    Is it possible the image is actually corrupt? Is it possible the host has a bad disk? Have you tried this same image on another machine.



  • @Wayne-Workman When I tried to download it to a virtual machine instead of a physical, I got the same disk read error but no graphical issues. I tried reuploading it as a multiple partition, single disk instead of single partition, single disk and am now trying to download it to a virtual machine.



  • @nengelhardt That model is listed in our working hardware list. The graphics card shouldn’t have any bearing on this. https://wiki.fogproject.org/wiki/index.php/WorkingDevices

    I think the oddly colored random characters might be due to somewhat incompatible generic video drivers that are used with the video card. Again, I don’t think this has any bearing on the actual imaging process. But, to be sure, you could take out the video card temporarily and try to image and just see what happens.

    Is this a “from scratch” image, or is it a manufacturer’s image?



  • @Wayne-Workman Fog 1.2.0 on Ubuntu Server 14.04.2 x64, Target and source is a HP 5800dc with a nvidia geforce gt610 video card.



  • What version of FOG are you running? What is the model of the physical target host?


 

583
Online

41.8k
Users

12.4k
Topics

116.7k
Posts