TFTP Issues



  • Poor me not having any luck with FOG.

    Today’s issue boot from network on any computer. Can’t find selected boot device press any key yada yada.

    On a Win7 Machine I try to TFTP 10.16.10.126 get undionly.kpxe
    Timeout occurred
    Connect request failed

    Even tried it from the same machine the file is on.

    atg@atg-HP-Pro-3500-Series:~$ tftp -v 10.16.10.126 -c get undionly.kpxe
    Connected to 10.16.10.126 (10.16.10.126), port 69
    getting from 10.16.10.126:undionly.kpxe to undionly.kpxe [netascii]
    Transfer timed out.

    Turned off Ubuntu Firewall. Checked DHCP Server 2012 r2 for OPT 66 and OPT 67. Rebooted the Fog Machine. Rebooted my DHCP Service on my server. Disabled Windows Firewall on my server.

    Checked my PCAP file with Wireshark didnt find anything.

    Any ideas?

    EDIT: Also says on machine No DHCP or proxy DHCP offers received.



  • @Danny-R Can you make sure tftp is running on your fog server? That link will tell you how to check it and start it.

    You can also try to get the file via TFTP through the CLI on the FOG server itself. If it succeeds, it’s a firewall issue. If it does not, you have either permissions or TFTP goofed. The Troubleshoot TFTP article shows how everything should be and gives commands for all of it.



  • @Wayne-Workman said:

    e you trying to network boot? Is UEFI enabled on it? Secure boot?

    Optiplex 9020 tried also with an HP 3400 MT.

    Same issue for some reason they both TFTP timeout.



  • @Danny-R What model of computer are you trying to network boot? Is UEFI enabled on it? Secure boot?



  • @Wayne-Workman The computer gets an IP in PXE mode and eventually gets a TFTP timeout.

    So it gets ip X.X.X.X then goes to TFTP . . . .

    Time Out



  • Check this article out: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP

    Are you positive that your computers are not receiving anything from DHCP? Does wireshark show DHCP requests and responses?


 

485
Online

41.8k
Users

12.3k
Topics

115.9k
Posts