DHCP Issues



  • I work in an environment where I can not make changes to the DHCP server, its all controlled by another group. I was able to come across an article [URL=‘http://www.fogproject.org/wiki/index.php?title=Integrating_FOG_into_an_Existing_Network_in_non_intrusive_mode’]here[/URL] that offers a solution for using FOG when you don’t control the main DHCP server.

    The article was helpful, and I followed everything as closely as I can, however when I boot to PXE it still pulls from another IP other than my FOG server. I can’t seem to get beyond that. I was hoping that someone here would be able to help me by pointing me in the right direction. Below are some screen shots if that helps…
    [ATTACH=full]80[/ATTACH]
    The DHCP shown here is my FOG server, which looks to be correct. However is seems to change to another IP and start loading a .WIM file from somewhere that doesn’t belong to me.
    [ATTACH=full]81[/ATTACH]

    It would seem that I am missing something…I just not sure what at this point.

    Here is my dhcpd.conf file according to the info in the link above.

    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;

    Fog’s IP address:

    next-server 160.129.19.168

    Subnet where you are going to use Fog

    subnet 160.129.19.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    default-lease-time 21600;
    max-lease-time 43200;
    }

    This machine will receive DHCP offer from Fog’s DHCP

    host DGHONWUA8430F98 {
    hardware ethernet 00:17:A4:41:CF:66;
    fixed-address 160.129.19.12;
    option host-name “test1”;
    filename “pxelinux.0”;
    #Default router (if needed)
    option routers;
    }

    Being new to Linux I’m sure I’m missing something. So please excuse my lack of understanding. If someone could help me sort this out it would be greatly appreciated.

    • Marshall

    [url="/_imported_xf_attachments/0/80_photo.JPG?:"]photo.JPG[/url][url="/_imported_xf_attachments/0/81_photo(1).JPG?:"]photo(1).JPG[/url]


  • Moderator

    This topic should not be in developer help, but I’ll give you some advice anyways.

    You want to run your server with ProxyDHCP enabled. This detects PXE boot requests on the network, allows the computers to get an IP address from the real DHCP server but get PXE boot details from your fog server.

    I have heavily modified the articles on the wiki with my experience using Ubuntu 10.04 LTS and Fog 0.32. The article title is
    [SIZE=6][B][URL=‘http://www.fogproject.org/wiki/index.php?title=Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server’][SIZE=4]Using FOG with an unmodifiable DHCP server/ Using FOG with no DHCP server[/SIZE][/URL][/B][/SIZE]


Log in to reply
 

391
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.