SVN update failed



  • Hello,
    my configuration:
    server Ubuntu 13.10_64B
    Fog SVN ver. 3596
    When I’m trying update to 3605 I get error.
    svn co https://svn.code.sf.net/p/freeghost/code/trunk /root/svn/trunk/
    Then
    cd bin
    ./installfog.sh
    Screenshot from 2015-06-26 11:33:50.png
    Installation fails on php5-fpm.
    The same information in /var/log/foginstall.log
    Any help?
    Regards.


  • Senior Developer

    Apparently the us.archive and us.security for old releases is no longer hosted at their relative release. So to fix, I have modified testing against the “old-releases” links and this appears to work properly.

    SVN 3616 should fix this for you, hopefully.



  • I get nothing but 404 not found for the update but I don have a solid internet connection as I’m able to bring up external webpages from the server.


  • Senior Developer

    What’s the output of sudo apt-get update



  • I’m getting the same issue that robza is with the “Preparing Package Manager” phase of the install.



  • @Tom Elliott
    update to version 3612 did’nt help
    Screenshot from 2015-06-26 14:06:45.png
    Installation failed during "Preparing Package Manager"
    Regards


  • Senior Developer

    Please try 3608.

    I didn’t know php5-fpm was trying to be installed of a different version, for that I’m sorry.

    I’m adding a php5-5.6 repository for Ubuntu now, and fog packages should now be updated as needed during installation.

    Hopefully this helps.



  • @ch3i yep,
    I tried apt-get install php5-fpm
    and
    dpkg -i php5-fpm_5.3.10-1ubuntu3.18_amd64.deb
    but I also get errors:

    root@v1fog:~/svn/trunk/bin# dpkg -i php5-fpm_5.3.10-1ubuntu3.18_amd64.deb
    (Reading database … 202106 files and directories currently installed.)
    Preparing to replace php5-fpm 5.3.10-1ubuntu3.18 (using …/php5-fpm_5.3.10-1ubuntu3.18_amd64.deb) …
    Unpacking replacement php5-fpm …
    dpkg: dependency problems prevent configuration of php5-fpm:
    php5-fpm depends on php5-common (= 5.3.10-1ubuntu3.18); however:
    Version of php5-common on system is 5.5.3+dfsg-1ubuntu2.6.

    dpkg: error processing php5-fpm (–install):
    dependency problems - leaving unconfigured
    Processing triggers for ureadahead …
    Processing triggers for man-db …
    Errors were encountered while processing:
    php5-fpm


  • Moderator

    @robza Have you try to install manually the package php5-fpm ?

    sudo apt-get install php5-fpm
    

Log in to reply
 

464
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.