Bug: Pending Mac addresses (being used and not being approved) and broken filter

  • Note: all hosts are using the legacy client

    As started here, I have noticed two bugs here: the first is that “approving” a pending mac address simply makes it disappear from the list of pending macs (still present as of 3587).

    The second is potentially more devastating. I could be wrong in my assumptions here but I think its pretty sound. What seems to happen is, is that MAC addresses are now being associated with a host even if they are only pending.

    This is a huge problem if you use virtual adapters. In my situation, virtual mac addresses get generated as part of the VMWare Workstation installation, which ends up being installed on ~500 PCs in our labs (IE 500 pcs will have the same two virtual mac addresses). This hasn’t ever been a problem and previously (1.2 and below), these cloned virtual addresses became “Pending” addresses. Simply ignoring their existence is fine and does nothing.

    Now, however, only one host has those mac addresses as “Pending”. But all other hosts who aren’t registered on FOG, or who have a problem initially retreiving their physical mac address (happens with some hardware configurations it seems), will check in thinking that they are that one host (because they have the same virtual address, which is still a mac address, and its associated with a host already. Despite being pending)

    If I remove those two virtual macs from being associated with that single host, another host will then associate itself with the virtual addresses next time it checks in to FOG. All the other machines that associated themselves with that single host will rename themselves to that host, which then means they’re unable to logon to the domain here.

    • If a machine is not registered on FOG, it will now add its MAC address to the list of pending addresses for the host to which it has renamed itself to.
    • If a machine is registered on FOG, but whose MAC doesn’t show up on the post string when checking in to FOG (happens when the FOG service starts too quickly on our SSD machines), it won’t add its MAC to the list for that host, but it will still associate itself with it.

    For now, I’ve created a single host called “BROKEN” and turned all services off and given it these two virtual macs explicitly. But this is still a bad situation to be in.

    The final issue is that the MAC address filter in the settings doesn’t seem to be listened to. Hosts can still exist and be registered and pending macs will still enter the list even if they start with the same string as listed in the FOG registration settings.

    So this comes down to three bugs in one:

    • Pending macs are still used
    • Approving pending macs just makes them disappear
    • Host filter doesn’t work

    If anyone has any questions or feedback, or corrections, please post 🙂

    Cheers guys!