TFTP open timeout but it seems to work



  • Hi guys, i love FOG but sometimes i hate it! it think our story is 1/2 love and 1/2 hate. :)

    I have a problem, the site is working well but i cant register any host or download upload anything because i have this annoying TFTP timeout error. !
    jzb3ir8.jpg
    I’m on ubuntu server 14.04.2 LTS and i had the 1.0.0 version of FOG, i updated it yesterday because it was not working.
    actually i have to manually start the mysql service after each reboot or i get the database error when i try to reach the FOG page, i fixed it before an ubuntu update.
    i also noticed that many FOG settings are duplicate, here an example.
    fog1.PNG

    i also tried to do

    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    

    and i can see the FOG ipxe menù but if i select something (like full registration) it give the TFTP open timeout screen.

    here the Config.class.php

    <?php
    /**
    * Class Name: Config
    * Initializes default settings.
    * Most notably the sql connection.
    */
    class Config
    {
            /**
            * Calls the required functions to define the settings.
            * method db_settings()
            * method svc_setting()
            * method init_setting()
            */
            public function __construct()
            {
                    self::db_settings();
                    self::svc_setting();
                    self::init_setting();
            }
            /**
            * db_settings()
            * Defines the database settings for FOG
            * @return void
            */
            private static function db_settings()
            {
                    define('DATABASE_TYPE',         'mysql');       // mysql or oracle
                    define('DATABASE_HOST',         'localhost');
                    define('DATABASE_NAME',         'fog');
                    define('DATABASE_USERNAME',             'root');
                    define('DATABASE_PASSWORD',             'abff29');
            }
            /**
            * svc_setting()
            * Defines the service settings.
            * (e.g. FOGMulticastManager,
            *       FOGScheduler,
            *       FOGImageReplicator)
            * @return void
            */
            private static function svc_setting()
            {
                    define( "UDPSENDERPATH", "/usr/local/sbin/udp-sender" );
                    define( "MULTICASTLOGPATH", "/opt/fog/log/multicast.log" );
                    define( "MULTICASTDEVICEOUTPUT", "/dev/tty2" );
                    define( "MULTICASTSLEEPTIME", 10 );
                    define( "MULTICASTINTERFACE", "eth0" );
                    define( "UDPSENDER_MAXWAIT", null );
                    define( "LOGMAXSIZE", "1000000" );
                    define( "REPLICATORLOGPATH", "/opt/fog/log/fogreplicator.log" );
                    define( "REPLICATORDEVICEOUTPUT", "/dev/tty3" );
                    define( "REPLICATORSLEEPTIME", 600 );
                    define( "REPLICATORIFCONFIG", "/sbin/ifconfig" );
                    define( "SCHEDULERLOGPATH", "/opt/fog/log/fogscheduler.log" );
                    define( "SCHEDULERDEVICEOUTPUT", "/dev/tty4" );
                    define( "SCHEDULERSLEEPTIME", 60 );
            }
    /**
            * init_setting()
            * Initial values if fresh install are set here
            * NOTE: These values are only used on initial
            * installation to set the database values.
            * If this is an upgrade, they do not change
            * the values within the Database.
            * Please use FOG Configuration->FOG Settings
            * to change these values after everything is
            * setup.
            * @return void
            */
            private static function init_setting()
            {
    define('TFTP_HOST', "192.168.148.25");
                    define('TFTP_FTP_USERNAME', "fog");
                    define('TFTP_FTP_PASSWORD', "abff29");
                    define('TFTP_PXE_KERNEL_DIR', '/var/www/fog/service/ipxe/');
                    define('PXE_KERNEL', 'bzImage');
                    define('PXE_KERNEL_RAMDISK',127000);
                    define('USE_SLOPPY_NAME_LOOKUPS',true);
                    define('MEMTEST_KERNEL', 'memtest.bin');
                    define('PXE_IMAGE', 'init.xz');
                    define('PXE_IMAGE_DNSADDRESS', "192.168.148.235");
                    define('STORAGE_HOST', "192.168.148.25");
                    define('STORAGE_FTP_USERNAME', "fog");
                    define('STORAGE_FTP_PASSWORD', "abff29");
                    define('STORAGE_DATADIR', '/images/');
                    define('STORAGE_DATADIR_UPLOAD', '/images/dev/');
                    define('STORAGE_BANDWIDTHPATH', '/fog/status/bandwidth.php');
                    define('UPLOADRESIZEPCT',5);
                    define('WEB_HOST', "192.168.148.25");
                    define('WOL_HOST', "192.168.148.25");
                    define('WOL_PATH', '/fog/wol/wol.php');
                    define('WOL_INTERFACE', "eth0");
                    define('SNAPINDIR', "/opt/fog/snapins/");
                    define('QUEUESIZE', '10');
                    define('CHECKIN_TIMEOUT',600);
                    define('USER_MINPASSLENGTH',4);
                    define('USER_VALIDPASSCHARS', '1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-');
                    define('NFS_ETH_MONITOR', "eth0");
                    define('UDPCAST_INTERFACE', "eth0");
                    define('UDPCAST_STARTINGPORT', 63100 );                                         // Must be an even number! recommended between 49152 to 65535
                    define('FOG_MULTICAST_MAX_SESSIONS',64);
                    define('FOG_JPGRAPH_VERSION', '2.3');
                    define('FOG_REPORT_DIR', './reports/');
                    define('FOG_UPLOADIGNOREPAGEHIBER',true);
                    define('FOG_DONATE_MINING', "0");
            }
    }
    

    and the .fogsettings

    ## Created by the FOG Installer
    ## Version: 1.2.0
    ## Install time: Mon 22 Jun 2015 15:30:03 CEST
    
    ipaddress="192.168.148.25";
    interface="eth0";
    routeraddress="         option routers      192.168.148.251;";
    plainrouter="192.168.148.251";
    dnsaddress="    option domain-name-servers      192.168.148.235; ";
    dnsbootimage="192.168.148.235";
    password="abff29";
    osid="2";
    osname="Debian";
    dodhcp="n";
    bldhcp="0";
    installtype="N";
    snmysqluser="root"
    snmysqlpass="abff29";
    snmysqlhost="localhost";
    installlang="1";
    donate="0";
    fogupdateloaded="1"
    
    

    The firewall is disabled and if i try to do tftp x.x.x.x get undionly.kpxe from a windows pc it can download the file…

    I don’t know what else i can do, do you have any suggestion?
    thanks a lot for your work guys.


  • Moderator

    @Lesso Nice article. :-)

    Feel free to request access to the FOG Project’s WiKi. :-) We need more people that are good technical writers.



  • @lessndro said:

    fortunately i found also this page https://www.designwright.com.au/articles/update-a-fog-server-ip-address because it explain how to modify the default.ipxe file (maybe someone should update the wiki!) and finally i can get in the FOG menù at every boot.

    :smile: Glad someone found my boredom useful and thank you for referencing my site rather than copying and pasting the info.



  • Hello Guys, i forgot to say one thing… yes it is working… we updated to trunk… BUT all this because Wayne Workman connected to our server and fixed it! thanks a lot for you help and your time!
    thanks thanks thanks


  • Moderator

    Got FOG working by upgrading to Trunk. However in this particular instance, a new but less concerning problem emerged. Duplicate fog settings… Read further here: https://forums.fogproject.org/topic/5326/two-new-fog-client-settings



  • unfortunately the restart didn’t change anything and also reinstalling mysql nothing happen.

    i did

    sudo apt-get remove mysql-server
    sudo apt-get install mysql-server
    

    thanks for the support


  • Moderator

    @lessndro I’d first try to restart the database. If that didn’t work, I’d remove then reinstall it.

    sudo service mysql restart
    

    MySQL

    apt-get remove mysql mysql-server
    apt-get install mysql mysql-server
    

    MariaDB

    apt-get remove mariadb mariadb-server
    apt-get install mariadb mariadb-server
    


  • yeah, a lot of hours wasted for a trivial error… actually we are for re-do all the network and add a lot of new servers, it can be the right time for do a complete documentation.

    what about the new error? I tried to google it but i can’t find others people with the same problem, i hope it is fixable!
    thanks a lot

    ----- UPDATE

    I discovered i can’t modify anything, for example if a try to create a new image i can do it but after i don’t see the new image in the list, is like i have only read permissions…


  • Moderator

    @lessndro :-) IP conflicts lol.

    To avoid that, you either need amazingly anal documentation skills from every single I.T. person in your organization,

    Or.

    Do not use static addresses, just simply make reservations in DHCP for your always-on equipment - and keep documentation on your reservations.
    Because, if DHCP fails, you’re screwed anyways till it’s fixed, right?



  • Hello guys, thanks a lot for your answers. Yesterday i was home so i didn’t tested anything, now i’m here. :)

    i tried to follow the ‘IP conflict’ way… i changed the reservation from DHCP to another ip that i was sure it was free (192.168.148.192) i updated the DHCP fog info (i put again the undionly.kpxe instead of the .kkpxe) and followed the first part of this wiki https://wiki.fogproject.org/wiki//index.php?title=Change_FOG_Server_IP_Address and fortunately i found also this page https://www.designwright.com.au/articles/update-a-fog-server-ip-address because it explain how to modify the default.ipxe file (maybe someone should update the wiki!) and finally i can get in the FOG menù at every boot.

    …and YES there was an ip conflict! from the dhcp server i could see the 192.16.148.25 (old ip) was free but probably a client took it because after i changed the FOG server to the new ip i could still ping 192.16.148.25 and i see a device from a ip scanner

    fog3.PNG

    unfortunately i don’t know how to understand which device it is because i tried to do ‘ping -a 192.16.148.25’ but i only get the ip address and also from Spicework if i try to search the mac address i can’t find it. I also tried to search the mac address on the DHCP server but nothing. Anyway it is just a curiosity because now i don’t need that ip.

    NOW i have another problem, but i hope this time it will be easier. Since i update FOG to 1.2.0 i noticed that i lost every host previously registered, not a big problem because i register only a few hosts because it was a pretty new installation… the problem is that i cannot register any new host. If i try from the pxe menù to do a quick or a full registration i get this error:

    sKzCzBm.jpg

    and also if i try to register a new host on the the website it says ‘Host added’ but if i i click on ‘List All Hosts’ i can’t see any host. do you have any idea?
    thanks a lot


  • Senior Developer

    @lessndro How hard would it be to get a Chat session going and potentially a Teamviewer session?

    My guess is the DHCP items are not setup properly and therefore not actually doing anything.


  • Moderator

    @lessndro You should do TCPDump at the earliest time possible.

    It’s the one thing that will reveal what’s going on.



  • the ip of the server is still the same (i also browse the FOG site with the ip in the address bar) and also in the dhcp server i see only it with his ip, maybe i can try to change it just for see what happen. thanks again


  • Moderator

    Just a simple thing to check but… since your DHCP server changed, maybe check for an IP conflict with the FOG server… or… maybe your FOG server is set to receive DHCP and it’s IP changed?



  • i forgot to say that the server was working well, than we moved our dhcp server to another machine (window server 2008) and FOG starts to has problems. at the start i thought the FOG has problems also with its site because i couldn’t reach it from my pc so i did many tries and i discovered my pc had a problem…many hours wasted but this is the best way to learn. so here the new configuration on the new dhcp server my colleague did. It seems ok for me, so i will try to do the TCPDump. Thanks again

    fog2.PNG


  • Moderator

    @lessndro It would seem that somehow this host is not getting the file… Normally this points to DHCP config being wrong… but if you think it’s right, I’d suggest running a TCPDump and seeing what the client is asking for, and where it’s asking for it, and to whom it’s asking…

    Check this out: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP

    There’s a bit in there about TCPDump.

    You might also check out the DHCP stuff too, and the rest of the article as well.



  • Hi Wayne,
    thanks for yours answer. unfortunately same error.


  • Moderator

    can you try to change your boot file to undionly.kkpxe and see if it makes a difference? This is done on your DHCP server.

    We can address the mysql issue in a moment… wanna get other things running first.


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.