"Dell Precision R5400" hangs in boot menu



  • Hi,
    I have multiple computers working perfectly with FOG. Then I have started using the “Advanced_boot_menu” option to make it possible for me to PXE boot into any of my installation iso files. I have got everything up and working except that one of my computer type “Dell Precision R5400” freezes if you press any key in the “boot_menu”. However if you do not touch any key it work as normal. (booting to harddrive, or uploading/deploying images )

    I have tried to use other random fog kernel’s without any success. Is there anyone else that have experience this issue? Is there any crash logs available when the computer freezes in the boot_menu?


  • Moderator

    @Frode-Woldsund It’s not a big deal. People come here for help / advice / to tell others things…

    and the people that hang here are willing to give help and listen lol.



  • … And now nothing makes sense anymore …

    1. I removed everything from the Advanced menu and rebooted my computer
    2. The PXE_Boot_Menu still freezes.

    I think it is time to try reinstalling FOG on another clean ubuntu and start from scratch again.
    I was 100% sure I registered all computers using PXE_Boot_Menu, but now I am only 90%…

    I am really sorry if I have been wasting your time with false information about the initial setup.
    Let me try to start from scratch, and I will inform you guys about the initial status of the R5400 computer.


  • Moderator

    @Frode-Woldsund

    This doesn’t have to be permanent - it’s just for troubleshooting. If you remove the ISO stuff from your menu, does it work normally?

    Because if it does, I’d expect this to be some sort of syntax issue possibly.



  • It might that I explain my problem completely wrong: So I will try to create a more step by step way to reproduce this issue I have:

    1. I have installed Fog 1.2.0 on a clean ubuntu server 15.04 in a XENSERVER environment. (Which we always do, and that always works fine on all or computers)
    2. We login to “fog web-interface” and change our default password but else everything if left to default
    3. Then we are able to register all our computers using the “PXE_boot_menu”
    4. We can create images and upload/deploy them from the “fog web-interface”, or manually start jobs from the PXE_boot_menu when register new computer
      All our computer including the R5400 does work perfectly until this point
    5. Then we want to add extra ISO files like a clean Windows7DVD to the ubuntu server, and we want to activate the “Advanced boot menu” from the “fog web-interface”
    • http://serverIP/fog/ -> Fog Configuration -> PXE Boot Menu -> Advanced Configuration Options -> and add something like this

    initrd ${boot-url}/service/ipxe/winpe_amd64.iso
    chain memdisk iso raw
    prompt
    autoboot

    1. When I now boot any computer(except my troublesome “DELL Precision R5400”) into PXE I still get the normal PXE_boot_menu, but with the additional “Advanced Menu” in the bottom of the list. And if I select it, it will boot from my Windows ISO file.
    2. When I now boot my “DELL Precision R5400” into PXE I still get the normal PXE_boot_menu, with the additional “Advanced Menu” in the bottom of the list. But if i press any key at this point, it will freeze. However if I do not press any key, it will boot as normal to my primary harddrive. (or if a task is active, it will skip the menu and go straight to the job, as inteded)

    So what is loading the menu, is that the undionly.xxx file, or is that a part of the kernel?

    • I have now tested unionly.kpxe, unionly.kkpxe, unionly.kkkpxe and a number of random kernels without anything helped so far.

    Also the Troubleshoot_TFTP seems to be to get TFTP working, but as I said all other computers are working fine, and also the R5400 is working fine except if you navigate in the PXE_boot_menu with the R5400 computer.

    Thanks for the help so far. Let me know if there is any way I can read our any debug messages from the PXE_boot_menu or if there are any logfiles available to help resolving this issue.


  • Moderator

    @Frode-Woldsund In some setups, a higher-up DHCP setting will override lower level DHCP settings. I’ve seen this happen at a larger organization once. The lower settings were set to use undionly.kkpxe but it wasn’t handing that out to clients properly. Turned out, a higher up global setting was overriding all the lower settings…

    Just something to look at.

    You can use TCPDump coupled with wireshark to verify that your clients are now getting undionly.kkpxe.

    There’s a small write up about doing those things here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP

    Maybe this is the issue, maybe not… maybe the hardware just isn’t compatible. Perhaps check the hardware lists?

    https://wiki.fogproject.org/wiki/index.php/WorkingDevices
    https://wiki.fogproject.org/wiki/index.php/ProblematicDevices



  • Yes you are correct: I am using 1.2.0 and "undionly.kpxe"
    But no changes when trying to load the “undionly.kkpxe”


  • Senior Developer

    I’m just guessing but you’re using fog 1.2.0 and, for the file to handout, undionly.kpxe? Can you try using undionly.kkpxe?


Log in to reply
 

456
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.