FOG not PXE boot anymore



  • I am running FOG 1.2.0 on Ubuntu 13.10. I previously was able to capture and image and deploy one. That was about 2 months ago.

    I tried to PXE boot today, and the client gets an IP address, and it starts initializing, but then something pops up really fast, so fast that I cannot pause the screen fast enough with an error that says:

    Unable to download…unsupported

    Then it exits the PXE screen.


  • Moderator

    Here is the ipxe files built with debugging, it also exits to shell instead of rebooting.
    tftpboot.tar.gz



  • @Hunter-Bonner said:

    @Wayne-Workman Looked at the list. here is the model machine I am using.

    HP EliteBook 2760p ✔ Default bzImage undionly.kpxe 2014-06-13

    I am using this model. and another which is a desktop

    HP Compaq 6200 Pro – 0.32 – 2011-08-04

    neither works. Previously, tboth of these I was able to PXE boot into the kernel, make an image, push an image. Now I cannot.

    Edit: I don’t want to quite Fog, and sorry if I came off as being not nice. I had no malice, just frustration. I appreciate everyone who has been helping me.

    FOG 1.2.0 only supports the kernels & inits up to a certain version, it’s early 3.ish something…

    Updates to 1.2.0’s kernels hasn’t happened in probably… over a year.

    With that said - You’re using the same kernel most likely as you were 2 months ago.

    Please check your Apache error logs via the FOG web UI and post any errors you see (don’t need to post copies of the same error, just one copy each is fine).

    Because suddenly two different models have stopped working… this leads me to think that either A. something went wrong with your FOG server, or was changed… or B. something on your network has changed that affects FOG.

    Please verify that your firewall is off, verify that SELinux is off. Perhaps uninstall and then reinstall PHP and Apache.

    And, if this FOG server is at your work, perhaps ask around and see if any changes were made to the network, the switches, firewalls, active intrusion detection systems, passive intrusion detection systems, vlans, filters, network appliances, etc… Make sure you don’t have an IP conflict on your network, that could cause this.



  • @Hunter-Bonner You may have already tried this, but I didn’t see it in the string of replies so I thought I would chime in. Have you tried using the undionly.kkpxe as your ipxe boot instead of the standard undionly.kpxe? Some of the machines in a lab I manage, Lenovo E31 workstations, have become problematic and using the undionly.kkpxe as the boot file is the only way I can get them to work 100% of the time. Most often they wouldn’t get ip addresses from DHCP, which is not your problem, but testing with the kkpxe couldn’t hurt.



  • @Wayne-Workman Looked at the list. here is the model machine I am using.

    HP EliteBook 2760p ✔ Default bzImage undionly.kpxe 2014-06-13

    I am using this model. and another which is a desktop

    HP Compaq 6200 Pro – 0.32 – 2011-08-04

    neither works. Previously, tboth of these I was able to PXE boot into the kernel, make an image, push an image. Now I cannot.

    Edit: I don’t want to quite Fog, and sorry if I came off as being not nice. I had no malice, just frustration. I appreciate everyone who has been helping me.



  • What is the model of this computer?

    Do other computers/models work?

    Have you looked at our Working Hardware / Problematic Devices lists?

    https://wiki.fogproject.org/wiki/index.php/WorkingDevices
    https://wiki.fogproject.org/wiki/index.php/ProblematicDevices

    And, if you quit on fog, that would be sad, but… this is a free and open source project with a limited volunteer development team and a limited volunteer moderator team… all of whom have 40HR+ work weeks elsewhere, and we try to help everyone here… And with an estimated 4,200ish FOG sites out there, sometimes things get crazy in the forums. We are doing our best to help you. The best way to get a problem resolved is to keep the conversation going, and provide lots of details, and be nice.

    If you want to improve FOG’s support, then hang out on the forums in your free time and try to help others, and learn more about FOG, and maybe make some contributions to the WiKi, and then convince your friends to do the same.



  • sorry for my 2nd and 3rd questions.
    and option 66 is your FOG server IP?
    Have you temporarily tried to disable firewall or iptables?



  • @TaTa undionly.kxpe I’m using Windows Server for DHCP



  • @ch3i said:

    @Hunter-Bonner said:

    @ch3i Sorry I do not know what you mean. I’m a total n00b to FOG.

    To boot your clients on PXE, you need :

    • An IP >> it’s OK
    • A DHCP option that specified the TFTP server (option 66) : the ip of the server >> NOK
    • A DHCP option that specified the boot file (option 67) : pxelinux.0 >> NOK

    I’m curious. Did you set option 67 to pxelinux.0 or undionly.kxpe?



  • @Wayne-Workman Hey I tried booting from another device and I finally got the error to pause. This is what it shows.IMG_0669[1].JPG

    I went to that URL, but I am not really sure how to update this?



  • O.k. I have verified that my TFTP service is running and is configured correctly. I even reinstall. 1.2.0 FOG just a few moments ago and it confirmed that settings were set correctly. I can login to the management portal without issues. The only thing that it’s doing is the same thing as yesterday, and that is saying that something is unsupported, which I cannot even read it goes by so fast.

    I’m stumped and frankly, I am about to the point of giving up on this project. I really don’t want o because the web interface and other things are nice.



  • @Wayne-Workman I used the command prompt. I got a transfer successful message when I ran the following command. tftp x.x.x.x get undionly.kxpe

    What’s next to try?



  • Windows can connect via TFTP at the command prompt…


  • Moderator



  • @ch3i There is no option for that in the drop down. I’m using what appears to be the latest version. There is FTP, SFTP, SCP and WebDAV.



  • @ch3i There is no option in that client for TFTP, just SFTP.


  • Moderator

    @Hunter-Bonner said:

    @ch3i yes was able to connect over ftp

    Not FTP but TFTP over port 69 (UDP).



  • @ch3i yes was able to connect over ftp


  • Moderator

    @ch3i said:

    As I asked :

    https://forums.fogproject.org/topic/5218/fog-not-pxe-boot-anymore/13

    @Hunter-Bonner Could you try to connect the FOG server over TFTP, using WinSCP maybe :p



  • @ch3i I just went to ipxe.org. Can access it fine.


 

378
Online

41.8k
Users

12.3k
Topics

116.0k
Posts