R51 and Samsung E252 - Unable to deploy/upload from older computers



  • Ubuntu 14.04.2 LTS
    FOG SVN 3504

    hi @ all

    i work with fog since version 0.27. now i have done the update from 0.32 to svn 3504. everythink runs fine with computers are not older than 5 years (lenovo t510, t520, t530). but now i can’t use fog for my old computers anymore.i can’t deploy old images and i don’t can upload new images with this computers. I had try different kernels and ipxe-versions and kpxe kkpxe and so on. but without success.

    i get following errors:

    Samsung E252- “Unable to locate image store” ,
    but nfs work’s fine

    IBM R51 - “Cannot find HDD on system” ,

    functionscript (usr/share/fog/lib/funcs.sh) gets no variables for $hd and $parts. in debug-mode, fdsik -l gives me all partitions and if i use the old function “getHardDisk()” from fog 0.32 in the new init.xz from svn,
    i get the right variables (hd=/dev/sda parts=/dev/sda1) but the script crash with illegal instruction error.

    where to look for the failure? is it ipxe, the kernel or the init.xz?
    anyone have any suggestions how to fix this?

    bobafat


  • Moderator

    I would say specify an older kernel for those models. Try kernels earlier than 3.18 and see what you find.

    For now, just using the kernel update feature is fine, but once you find some that work, you can make copies and specify the kernel for those particular hosts inside their general menu.



  • my solution for the moment is to use virtualbox with fog 0.32 on ubuntu 12.04.5 LTS for this computers and hope for a quick end of life for this pc’s.

    greetings bobafat



  • FOG SVN 3564

    thx for the anwsers.

    I have done all suggestion from user Wayne Workman without luck. I get the same errors. I had used undionly.kkpxe and was trying to re-register the hosts. it was only possible for the samsung. ibm r51 stop the quick- and the full registration with the same error like before (Cannot find HDD on system).

    I will try the suggestion from Tom Elliott in the next few days and report back, if i find something news.

    thx so far.



  • and no option for HDD in bios



  • I am always at lvl 7 and debugging on, lol.

    i’ll screen in one hour


  • Senior Developer

    @TheKor, can you increase the Console Loglevel and enable kernel debugging? This can be done from the GUI. I imagine drivers are missing for this HDD, or it’s reporting the HDD as a non-block level device.



  • I’ll try with IBM R50 and last SVN and have the “Cannot find HDD on system” error too


  • Moderator

    I know that there have been very recent changes to the latest revision to allow more unique hardware.

    Try bumping up to the latest, and see if it helps.

    Also, perhaps you could try deleting one of the problematic hosts from your Host Management page and then re-register… sometimes old kernel settings get carried over in the DB… So I recommend trying to remove / re-add a problem host.

    also, for these older machines, I’d recommend trying with undionly.kkpxe (in combination with whatever else you try).

    Please report back what you find so we can further assist.


Log in to reply
 

482
Online

38916
Users

10687
Topics

101370
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.