SVN 3526 - Snapins not in "Active Snapin Tasks" after scheduled task is triggered



  • When scheduling a (single host) download task, it is triggered correctly and the download task appears in “Active Tasks”. But the snapins linked to the host do not appear in “Active Snapin Tasks”.
    (Scheduled download/upload tasks are also is kept in “Scheduled Tasks” with “Ran at: …” in the “Start Time” column - don’t know if this is behavior is ok)

    Starting the download task directly by Instant Deployment adds the snapins correctly to “Active Snapin Tasks” and runs them properly after downloading the image created.

    This behavior also was like this in some svn version before. I’m not sure about the stable version 1.2.0 anymore.

    The fog server runs on Ubuntu 14.04. The 4 fog services, mysql, tftp are all up and running - all of them are delayed at startup by rc.local .



  • Just did a group download task (instant deploy) with SVN 3575 - and the basic snapin behavior seems to be fine now.
    The snapin tasks are displayed and applied correctly. To put the computers in the domain also is faster (tried the new fog client with this svn)

    Thank you very much!

    (I hope next week I can test a scheduled group download task run and the the behavior with the the deletion of a download task when deleting all (to a host) connected snapin tasks)



  • Thanks for the fast response and that great program in general.

    I tested SVN 3562 and SVN 3563. The snapins now appear correctly after a single host download task (instant and delayed) is started.
    But for group download tasks the snapins still don’t appear in “Active Snapin Tasks”.

    And I found another bug with snapins run by a download task (instant / delayed):

    • After all snapins, that have been run with a single host download task, are deleted/canceled from “Active Snapin Tasks” , the download task vanishes from “Active Tasks”.
      • The download task vanishes either when it is queued or already downloading (tested with active download in b3563 only since in b3562 the pxe-boot seemed to be broken and and things have been reset to an earlier svn).
      • After finishing the image download it can’t complete correctly and repeats the message “No Active Task found for Host: test (MAC_address_from_test)” when trying to update the “Computer Database Status”
    • The download task will be still there if 1 snapin task from the host is left in “Active Snapin Tasks”.

  • Senior Developer

    I confirmed the problem and it appears that this should be fixed in SVN 3562. Thanks for reporting.



  • just updated to SVN 3559 and created another scheduled task - after the task was run, it was the same behavior as before.

    Additionally I tried download tasks for a group - I noticed the following:

    • scheduled download task: tasks appeared in “Active Tasks” at the given time, no snapins added/active
    • instant download task: tasks appeared in “Active Tasks” directly, also no snapins added/active

  • Senior Developer

    @tian Can you try updating to current SVN and attempt re-creating the scheduled task?

    I’m going to verify, attempt to replicate this myself as well, and hopefully confirm and fix this issue. However, knowing where to start first is a bit better I think.


Log in to reply
 

375
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.