Scheduled tasks bug



  • Hi,
    first: the new forum is amazing. Minimal 'n cool,
    well done!

    About the problem: I can schedule tasks for groups and they run smoothly, the only
    issue is that in the ‘scheduled tasks page’ I cannot see table or listed task. So no way
    to cancel or view the status of these…
    thanks for the help!

    A.


  • Developer

    The scheduled task will be in the ‘scheduledTasks’ table.

    Look for ‘stIsGroup’ = 1 and ‘stGroupHostID’ = to the Host or Group ID

    Latest rows will have the largest ‘stID’



  • I got the same problem. Look at this[URL=‘http://www.fogproject.org/wiki/index.php?title=Multicasting’] http://www.fogproject.org/wiki/index.php?title=Multicasting.[/URL]
    But I dont try Scheduled Tasks, becose ware I don’t have the time for it.
    What I said before, try this.
    [quote=“Egbert Verhage, post: 314, member: 67”]Check of you username and password of you mysql datebase is correct!
    Edit [I]/opt/fog/service/etc/config.php [/I]and /var/www/html/fog/commons/config.php
    Or maybe the mysql server don’t allow to connect from extern host. Set in you mysql config the bind addres on 0.0.0.0.
    And in the config above set the host to you IP of the server(Of the local network).[/quote]
    The multicast is trying to connect to the mysql server but it won’t becose the mysql server don’t accept it.

    (If you are from The Netherlands, I have here a manual whit the problem of multicast)



  • yes, now I can login into phpmyadmin and play with the DB.
    I had a failed Multicast session who kept running. Now I drop it from
    MulticastSession table but it keeps run when I turn on one of the machines.

    Then I checked ScheduledTasks table and all the others but there are no tracks of this query. Also
    I rebooted the machine running FOG but no luck

    :(



  • Alright!
    I hope that it works now!

    Greets Egbert



  • okey okey you can strap and laugh me in face :D

    I used ‘root’ in the phpmyadmin GUI and it let me in…



  • [quote=“Egbert Verhage, post: 314, member: 67”]Check of you username and password of you mysql datebase is correct!
    Edit [I]/opt/fog/service/etc/config.php [/I]and /var/www/html/fog/commons/config.php
    Or maybe the mysql server don’t allow to connect from extern host. Set in you mysql config the bind addres on 0.0.0.0.
    And in the config above set the host to you IP of the server(Of the local network).

    (Sorry, English is not very well)[/quote]
    thanks for you reply!

    in /commons/config.php I got this:

    [PHP]define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );[/PHP]
    As everyone the credentials to login in fog GUI are ‘fog’ and ‘password’. And DB has
    no passw.

    PS: I’m trying to connect from the local machine, that runs
    fog too.



  • Check of you username and password of you mysql datebase is correct!
    Edit [I]/opt/fog/service/etc/config.php [/I]and /var/www/html/fog/commons/config.php
    Or maybe the mysql server don’t allow to connect from extern host. Set in you mysql config the bind addres on 0.0.0.0.
    And in the config above set the host to you IP of the server(Of the local network).

    (Sorry, English is not very well)



  • thanks!

    I tried but using fog user and passw it says:
    [QUOTE]#1045 Cannot log in to the MySQL server[/QUOTE]

    EDIT: yes, I just set the config file to allow NOPASSWORD login


  • Developer

    PHPMyAdmin can be ran directly from your FOG server.
    [code]apt-get install phpmyadmin[/code]
    Then access it at
    [code]http://fog/phpmyadmin/[/code]
    Use your FOG MySQL Username and Password



  • I mentioned this in the old forums. You can use MySQL Workbench or phpmyadmin to view and remove those tasks.


  • Developer

    This is a known bug with Schedule Group Tasks in 0.32. This issue will be fixed in 0.33.

    Thank you for reporting. Please report any other bugs you find.


Log in to reply
 

376
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.