SVN 3530 Hostnamechanger giving 1326 errors.



  • I have tried everything I have read here about issues with this. Tried my main administrator account and its password tried the secondary account for joining AD and neither work. I was using the latest .84 fog service during all these reboots and tests. Here is the setup with new client

    School.LAN
    Blank for OU
    DOMAIN\Username I also tried just username
    Password

    I decided I would pull the legacy service I had on another machine and reinstall it. Computer immediately joins the domain with my secondary account. Here is legacy client where it just booted up the machine and did it.

    School.LAN
    Blank for OU
    DOMAIN\Username
    Password


  • Moderator

    @Etrain

    lol… that’s definitely why it wasn’t working.

    Additionally, with that check box checked, you do not use FOG Crypt any longer.

    You type your plain text password in, hit save, and it gets encrypted with an insanely secure security/encryption system.

    Also, with that checkbox checked, the Active Directory section on the host management page only accepts plain text (if you type it in manually) and then encrypts whatever you type there. The auto-populate would just populate the already-encrypted password.



  • That was never checked for me… Could that be why the new client was not working? The more you know…


  • Moderator

    @Etrain said:

    Ok Thanks for all assistance Wayne. I will continue using legacy since its working and I need to keep moving forward with summer work as well.

    Make sure you uncheck the “new client” box in Fog Config - Fog Settings - Fog Service.
    Then, reset all your client’s AD stuff using groups.



  • Ok Thanks for all assistance Wayne. I will continue using legacy since its working and I need to keep moving forward with summer work as well.


  • Moderator

    @Etrain

    I have no idea… When I needed the New Client to work and it didn’t (a month ago?), I went to the legacy client for this summer because I had to get things going.

    I’ll revisit the new client in the fall, hopefully things are working better then.

    In the mean time, @Jbob is the new client developer, and I’m sure he’d be interested in helping you.



  • Ok I thought I had missed the decimal as well… yes I was using .8.4 client on said machine and it will not join the domain on that client continually retries but always returns password or username error.


  • Moderator

    Oh… You missed a decimal.

    When you say “.84 fog service”, I assume FOG version .84 /w legacy client.

    The NEW Client is actually 0.8.4 … sorry for the confusion.



  • When you say new client do you mean the one .84 version that came with svn 3530? I was using that one intitially and I saw in the log file that it kept trying every few minutes but was giving me the username password error.

    This was the point I decided to reinstall legacy client and it went right through without changing any passwords etc.

    If I am reading right it sounds like you are saying I need fresh builds without ever having the legacy client?

    I have got about 13 different machines maybe a few more that I would rather not have to do full rebuilds and updates on :(

    But as you described I did deploy from .32 and then just did my updates to all machine and was planning to reupload to svn 3530 I did a fresh linux build and brought nothing over.


  • Moderator

    I’ve encountered something like this.

    Turns out, when you update FOG to… any version… some sort of certificate/communication/trust issue happens, and old images made with older versions of FOG (using the legacy client) won’t join the domain. I don’t fully understand it, I just know that joins don’t work with older images after an update.

    But after doing what you just described, it works.

    The legacy client only tries to join the domain on the boot after imaging… if it doesn’t work, it doesn’t try again.

    FTR, the new client doesn’t have this issue.


Log in to reply
 

392
Online

38920
Users

10688
Topics

101407
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.