Hostnamechanger not joining domain. Error 1355.



  • We have created several images, and they download fine. Hostnamechanger does reboot system and rename the computer to the appropriate name. However, joining the domain is a different issue. Let me go into a little more detail.

    We have multiple sites that are subnetted out. Each scope has the 66 and 67 options set. That is not the issue. At all of our remote sites, the computer will not join the domain. The fog.log gives the error 1355 when it tries to join. However, if we use the same image on the same local subnet as the FOG server, computers join the domain fine. Same options are set here, there is no difference in the DHCP setup. At the remote sites, we can manually join the domain, we can even use the netdom command no problem.

    Any thoughts?


  • Moderator

    Glad you got it working! and, that info is good to know.

    I am going to have to set FOG up at our central location for something like 27 buildings soon… glad to know what to use now!

    At the moment, I’m sort of the lone ranger using FOG in just one building, and everyone is envious of my 4 minute image deployment time, with auto naming and auto joining to domain… and web functionality. And, the people at Acronis screwed up when my manager called them up with a list of basic questions about their network solution… and nobody he got on the phone with could give direct answers… so they missed out on something like a $50,000 sale lol. My manager wants to move forward with FOG now. :-)



  • Using the FQDN seems to be working. We were able to join a computer to the domain from a different subnet.

    Thanks Wayne for your help! Not sure why FOG client is not using our DNS entries, but it worked.



  • I will give that a try and then reply back when complete. Thanks Wayne! I’m crossing my fingers.


  • Moderator

    Could you try the FQDN in the FOG Active Directory Defaults… just to see what happens?

    After setting that, you’ll need to “update” those settings on a test host. You’d uncheck the box, clear the fields, then check the box and it should populate.

    Please note that changing the Active Directory Defaults does not affect any host unless you apply those settings to the hosts (hence defaults).

    The old Legacy Client might not care about your DNS pointers lol. and your problem suggests this.



  • Thanks Wayne.

    In the FOG AD settings, we use the sloppy domain name. In our DHCP scopes, we point to the FQDN.

    At the remote sites, imaging works great, but no domain join. On FOG server local subnet, imaging works great AND domain join works.

    FOG IP address is set correctly on the client for imaging. Like I said, everything works great local subnet, but just doesn’t join domain when away from server subnet.

    All settings on the client, AD settings, FOG Configuration, everything is set right.

    It’s something about the remote sites. Just not sure what. DHCP has the correct settings (66 and 67). set exactly the way as the local server subnet.


  • Moderator

    .local ?

    When I say FQDN… well… here’s an example that most schools follow…

    Sloppy Domain Name:

    MyDomain

    FQDN:
    MyDomain.MyOrganization.k12.ny.us

    You said you use the sloppy name at these remote locations… and it works? This means you have DNS records to translate the sloppy name to point to the correct Domain Controller?

    Another more basic question is… When you’re building your images, did you ensure the correct FOG IP address (not name) was entered? And all the services on the client itself are enabled?

    Also, I believe that the domain joining has to be enabled within the FOG web UI.
    FOG Management -> FOG Configuration -> Active Directory Defaults

    You have to use the FOG Crypt program to encrypt your AD password, then take the encrypted string and stick it into the password field in there.

    Then, on the hosts, you have to go to the Active Directory section, and click the “join domain” checkbox. If the fields are blank, they should auto populate with the info you set inside the Active Directory Defaults section.



  • To clarify, we are using the FOG client that got installed with 1.2.0. I just read that a new fog client has started to be distributed for testing. We are not using that client.



  • We are on Fog 1.2.0., using the new FOG client.

    As far as domain, we just use the first part of the domain name, we do not use the .local at the end.


  • Moderator

    Are you using the Legacy Client, or the New FOG Client? And if you’re using the new FOG client, which version?

    Also, which version of FOG? (specifics).

    Are you using a FQDN or a Sloppy Domain Name (sloppy is fine if it’s local)?


Log in to reply
 

387
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.