Boot Problem with restoring image to HP Z Series (Z230) & Clonezillia IPXE Boot



  • Hi

    We have about 75 new Hp Z230 and would like to use fog…

    Fog 1.2.0

    Problem:

    I setup a z230 with RAID1 (2x 1TB)
    Installed windows 7x64 & patch
    Run Fog Prep & upload image.
    Fog image setting: multiple partition image single disk ( not resizable) & All tried ALL DISKS

    Image uploads fine… Deploying it to another machine i get this: Degraded raid1 and it wont boot.

    If i run bootrec /rebuild bcd it will boot windows… Then my problem is the RAID1, soon as i select the second drive and say rebuild it wont boot and its need to boot windows to start rebuild.

    I would like to multicast deploy this image and need to do with without affecting the raid1!
    IMG_3345.JPG

    IMG_3344.JPG



  • @Deastrom That’s amazing, thank you!



  • Not sure if this has been resolved or not, but this site was a great help to me in setting up my Clonezilla PXE boot; http://clonezilla.org/livepxe.php .

    you’ll need initrd.img, vmlinuz, and filesystem.squashfs from the .iso or .zip of clonezilla.

    Here’s what I ended up with…

    :Clonezilla
    initrd http://<fogIP>/fog/clonezilla/initrd.img
    chain http://<fogIP>/fog/clonezilla/vmlinuz boot=live config noswap nolocales edd=on nomodeset ocs_live_run="ocs-live-general" ocs_live_extra_param="" keyboard-layouts="" ocs_live_batch="no" locales="" vga=788 nosplash noprompt fetch=http://<fogIP>/fog/clonezilla/filesystem.squashfs
    ||
    goto MENU
    

    and that has me booting to Clonezilla just as if I picked the default menu booting from usb.



  • Ok… If you get it working, let us know.

    I’ll be working on it too.



  • @Wayne-Workman

    Im not mounting the ISO it self… just the below files are needed or the extracted iso.

    kernel http://${fog-ip}/${fog-webroot}/iso/clonezilla/vmlinuz
    initrd http://${fog-ip}/${fog-webroot}/iso/clonezilla/initrd.img



  • @Trixsta101

    Last night before everything went wrong, I noticed the init and kernel are in a folder on the Clonezilla iso called “boot”…

    Have you tried leaving those files where they are? and do you have the iso Mounted to the directory that is specified in that path below?



  • @Wayne-Workman

    Ok Great…

    Just tried this with no luck… didn’t get as far as the the last config.

    http://bootallthethings.blogspot.co.nz/2013/01/ipxe-clonezilla.html

    kernel http://${fog-ip}/${fog-webroot}/iso/clonezilla/vmlinuz
    initrd http://${fog-ip}/${fog-webroot}/iso/clonezilla/initrd.img
    imgargs vmlinuz boot=live config noswap nolocales edd=on nomodeset ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_keymap="" ocs_live_batch=“no” ocs_daemonon=“ssh” usercrypted=Kb/VNchPYhuf6 ocs_lang="" vga=788 nosplash noprompt
    fetch=http://${fog-ip}/${fog-webroot}/iso/clonezilla/filesystem.squashfs
    boot || goto failed
    goto start



  • @Trixsta101

    I’m still working on this at the house, making good progress though… but disaster struck last night and the AC adapter for my small business router died… :-(



  • I have also found this, bot have no idea on how to get this to boot from fog ipxe… Hopefully someone might have an idea of the config.

    https://gist.github.com/devicenull/3896763

    :imaging
    set image_name your-image-name

    kernel http://${next-server}/tools/clonezilla-live/vmlinuz initrd=tools/clonezilla-live/initrd.img boot=live live-config noswap nolocales edd=on nomodeset ocs_daemonon=“ssh” ocs_live_run=“ocs-live-restore” ocs_live_extra_param="–batch -g auto -e1 auto -e2 -r -j2 -p reboot restoredisk ${image_name} sda" ocs_live_keymap="/usr/share/keymaps/i386/qwerty/us.kmap.gz" ocs_live_batch=“yes” ocs_lang=“en_US.UTF-8” vga=788 nosplash fetch=http://${next-server}/tools/clonezilla-live/filesystem.squashfs ip=eth0:${netX/ip}:${netX/netmask}:${netX/gateway}:8.8.8.8 ocs_prerun="mount -t nfs ${next-server}:/home/partimag /home/partimag"
    initrd http://${next-server}/tools/clonezilla-live/initrd.img
    boot



  • You work fast…

    I rebuilt all my servers this weekend… I’m still running updates lol.



  • @Wayne-Workman @Developers @Tom-Elliot

    Currently this is the closest to booting i have… error message below

    :clonezilla-live-2.3.2-22-amd64
    kernel http://${fog-ip}/${fog-webroot}/iso/clonezilla/vmlinuz
    initrd http://${fog-ip}/${fog-webroot}/iso/clonezilla/initrd.img
    imgargs vmlinuz root=/dev/nfs boot=clonezilla netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/clonezilla/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=us mirror/country=US
    boot || goto failed

    FullSizeRender-clonezilla.jpg



  • It’s probably a step in the right direction.

    Keep searching though, but you’d probably have the best luck searching in the forums here for ISO tons of people have got it going on various versions of FOG.

    I’ll only be addressing the next release (the one you’re using), FOG 1.3.0



  • @Wayne-Workman
    came across this https://gist.github.com/robinsmidsrod/dc0dc70adba8dcd79cdf

    not sure if this would help? tried adding the forth line with no luck

    #!ipxe
    kernel /live/vmlinuz
    initrd /live/initrd.img
    imgargs vmlinuz boot=live username=user hostname=trusty config quiet union=overlayfs noswap edd=on nomodeset noeject locales= keyboard-layouts= ocs_live_run=“ocs-live-general” ocs_live_extra_param="" ocs_live_batch=no ip= nomodeset vga=normal nosplash
    boot



  • Check this post out: https://forums.fogproject.org/topic/4790/how-to-add-live-cd-iso-to-fog-1-2-on-ubuntu-12-04

    I’m going to be following this also, tonight.

    This ISO network booting question comes up over and over and over and over and over. It’s a never-ending question lol.

    If I can get it working, I’m going to make a very nice WiKi article on it.



  • @Wayne-Workman

    will give this a shot… would be good to have a backup if it works on software Raid.

    trying to add it to the ipxe boot menu, have this but wont boot… Any idea on how to live boot it?

    :clonezilla-live-2.3.2-22-amd64
    kernel http://${fog-ip}/${fog-webroot}/iso/clonezilla/vmlinuz
    initrd http://${fog-ip}/${fog-webroot}/iso/clonezilla/initrd.lz
    imgargs vmlinuz root=/dev/nfs boot=clonezilla netboot=nfs nfsroot=${fog-ip}:/var/www/fog/service/ipxe/clonezilla/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=la mirror/country=US
    boot || goto failed
    goto start



  • @Trixsta101

    Clonezilla has no affiliation with FOG, and it does not require a server.

    It’s a bootable disk used for imaging. I only suggest this because, hey, if it works, that’s great. You have 75 computers to image, right?

    http://clonezilla.org/



  • @Wayne-Workman

    No I haven’t… Is that an addon to fog or does get require another server setup?



  • Have you tried Clonezilla ?



  • @Wayne-Workman

    When you restore the image the disk become a non member disk… so to rebuild it asks you to select the new disk and this is the one with the image on it… if you proceed you close everything.

    If i was to restore to 1 disk (with no raid)… when i create the raid1 it formats them both.



  • If this is a basic RAID 1 configuration,

    Why not just disable it temporarily, and upload your image from a standard disk, then re-enable it and have RAID rebuild the clone?

    Then, when you want to image, disable RAID, image, then enable RAID and have it rebuild the clone?


 

493
Online

41.5k
Users

11.9k
Topics

113.3k
Posts