Fog captures ENTIRE hard drive



  • Hi all,

    I’m running Fog on Ubuntu server 14.04 with all of the latest updates.

    I can successfully inventory a computer in Fog and create an image. I choose “upload” on the server, then run Fog Prep on the computer (Win7 x64), reboot and successfully boot to Fog. But when it captures the image, it captures the ENTIRE hard drive. I figured this out the hard way when I tried to image a machine with a 1TB hard drive.

    I think I’ve narrowed it down to the partitions on the hard drive. I only have one OS installed on the computer I’m trying to capture, but it has multiple drives: C: (normal use), D: (HP_Recovery), and E: (HP_Tools). For image type, I’ve tried Single Disk - Resizable, Multiple Partition Image - Single Disk (Not resizable), and Multiple Partition Image. If it doesn’t capture the entire hard drive, then the image size is about 5MB.

    What’s the deal? Do I have to build a completely new install of Windows so it only has C: and “System Reserved” for the drives, or is there a way to get Fog to work with have multiple drives like my situation?



  • @Wayne-Workman Thank you sir! This fixed the issue.



  • @rothrock88 That’s an FTP issue.

    Check this out: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

    Give ya a hint… credentials.



  • @Wayne-Workman I deleted all drives but C: and System Reserved, and set the Image type to “Single Disk - Resizable”. This seemed to resolve the issue of the image size.

    But now, when I try to deploy the image, Fog states that I need to “upload an image”. It seems that the uploaded image isn’t associated with a Host (see attachment). Any tips on this?fog.PNG



  • @rothrock88

    Resizeable is normally the best choice. It should always be your first choice for Windows PCs that have only one OS installed and one HDD.

    I’ll explain a little…

    When you upload using resizeable - during the upload process (before partclone), FOG resizes the partitions on the drive. It shrinks them down so that only a gig or so of free space is left on each partition. If partitions are super tiny (like system reserved), they do not get resized. Partclone then takes an image, it compresses the data client-side and then sends it to the FOG server bump by bump. After the upload is complete, FOG expands the partitions on the source machine to fill the disk.

    RAW does not compress anything, does not resize anything, and uploads the whole thing.

    Single disk not resizeable - does not resize, but does compress.

    All that said, 1.2.0 is aging… and I don’t know how it handles more than two partitions on the source disk. I’ve never actually used 1.2.0 in production. Because of custom multicasting configuration at my place of work, and because of Tom’s (the senior developer) ridiculously fast feature implementation to support custom Multicast addresses and ports, I only use FOG Trunk at work.

    It might be that 1.2.0 doesn’t handle more than two partitions? I’m not sure… @Developers would have to chime in on that.

    But, if at all possible, could you eliminate the HP_Recovery partition and the HP_Tools partitions?

    Honestly, if FOG can image them in mere minutes, what point is there to have a recovery partition? None, in my opinion.

    Alternatively, you could also wait for the Developers to chime in, or you could jump to FOG Trunk and try your luck with that. But I really think the issue is your several partitions on this model.

    To explore FOG Trunk (please read through the article): https://wiki.fogproject.org/wiki/index.php/SVN



  • @Wayne-Workman I’m running Version: 1.2.0



  • @rothrock88

    I re-read through all this.

    What version of FOG are you using?



  • @Wayne-Workman Will give it a shot, thanks. I’m off site today but I’ll definitely try it next week.



  • Try uploading without using Fog Prep?

    I’ve never used Fog Prep… ever.

    And “resizeable” is your ticket.



  • No, apparently there is something going on that I haven’t run into before. List the version of FOG you are running and maybe some pictures of the screens leading upto and including the start of the Partclone, along with a screen capture of the Image setup page for this Image. I don’t have much experience troubleshooting FOG so I will take a look but probably one of the more informed on the forums will take a look.

    I created a Win 7 x64 VM that I use as a generic image for all my machines I rarely pull an image from a hard machine.



  • @Tim.Trageser Secure boot is not enabled. Would you recommend enabling it?



  • This post is deleted!


  • No BitLocker to speak of since this is happening with multiple machines. But they ARE all the same make and model. I’ll have to check the BIOS. Thank you, I’ll update when I find an answer to that.



  • Is Secure boot turned on in the BIOS of the machine being captured? I know when I was playing around with Windows 8 it was capturing a RAW image and I think that was the cause. That or the drive was encrypted because of BitLocker.


 

507
Online

41.8k
Users

12.3k
Topics

116.0k
Posts