ipxe.org/4c116035 timed out



  • Hello, i have upgraded to version 1.2 since few month now and it works well, but since last week i get a new error :
    connection timed out (http://ipxe.org/4c116035) error
    if i reboot the server it work again for few hours/day and then same error.
    Since it worked for past few month i don’t think there is a problem with the configuration so any idea of what the problem can be ? (and how to solved it )
    Thanks


  • Moderator

    This post is deleted!


  • This post is deleted!


  • I have acl/vlan (but they have not changed recently only my fog version have changed) and the fog server is on the same vlan as the computers


  • Moderator

    @alpilles.info said:

    Hi, i have notice with many test that the problem seem to be random, i put a task download or upload computer half time this work wells half time i have this error (and i reboot and do it again no error) like i said totally random i don’t have any idea why but that’s annoying, is someones has ideas.
    Thanks

    Hi,

    How your network is configured ? (ACL, VLAN, …)



  • Hi, i have notice with many test that the problem seem to be random, i put a task download or upload computer half time this work wells half time i have this error (and i reboot and do it again no error) like i said totally random i don’t have any idea why but that’s annoying, is someones has ideas.
    Thanks



  • @Tom-Elliott said:

    service nfs-kernel-server status

    yes it’s that :
    service nfs-kernel-server status
    nfsd running

    ubuntu 14

    so the problem is elsewhere, but like i said right now it work with the FOG_PXE_IMAGE_DNSADDRESS but it used to work without it, it’s very strange :)
    Thanks for your help.


  • Senior Developer

    I believe the correct command is:
    sudo service nfs-kernel-server status

    If on Ubuntu 15? or Debian 8 it would be:
    sudo systemctl status nfs-kernel-server.service



  • yes nfs-common status doesn’t exist, for now i have add my dns server in FOG_PXE_IMAGE_DNSADDRESS andi turn off FOG_USE_SLOOPY_NAME_LOOKUP
    it seem to work better i will do some other test.


  • Moderator

    @alpilles.info said:

    Hi, ok thanks.
    I have run the scripts but i got some error :+1:line 19 entire number expected
    nfs: unrecognized service
    iptables: unrecognized service
    Usage FOGMulticastManager {start|stop|restart}
    FOGSnapinReplicator: unrecognized service
    Usage FOGImageReplicator {start|stop|restart}
    Usage FOGScheduler {start|stop|restart}
    sed: -e expression n°1, caractère 4: command `s’ not finished

    (i have translate some line because it was in french), else everything seem fine in the log file.

    For NFS the command is (I think) :

    service nfs-common status
    

    For FOG services, in 1.2 there is no “status” added in these scripts.



  • Hi, ok thanks.
    I have run the scripts but i got some error :+1:line 19 entire number expected
    nfs: unrecognized service
    iptables: unrecognized service
    Usage FOGMulticastManager {start|stop|restart}
    FOGSnapinReplicator: unrecognized service
    Usage FOGImageReplicator {start|stop|restart}
    Usage FOGScheduler {start|stop|restart}
    sed: -e expression n°1, caractère 4: command `s’ not finished

    (i have translate some line because it was in french), else everything seem fine in the log file.


  • Moderator

    @alpilles.info said:

    For my information why is it trying to reach ipxe.org it need internet to work ?

    Hi,

    Don’t need to have Internet on the server, it’s just the url to the error code.

    Regards,
    Ch3i.



  • Hi, i will try tomorrow and tell you the result, thanks


  • Moderator

    Can you run the troubleshooting script found here: https://forums.fogproject.org/topic/4581/let-s-make-scripts

    And see if it points anything out?

    I’m not sure if it’ll help but it’s a shot in the dark, you know?



  • Where can we choose that ? The strange thing is that if the server is reboot it work then same problem little after, and i haven’t changed the configuration since 4 month (the problem just occur recently)
    For my information why is it trying to reach ipxe.org it need internet to work ?
    Thanks


  • Senior Developer

    Then something is not configured properly. Maybe your FOG server is set to look for hostname?



  • In my dhcp (that is manage by a windows 2008 server) there is the ip not hostname
    my fog server is already on a static ip (reserved in dhcp)


  • Senior Developer

    @ch3i I’m going to guess servername. I’ll even go one step further and guess that there is no static IP address for this host, and the old entry for the servername is what’s listed in the DNS records which is why its failing in this particular instance.

    @alpilles.info Can you try setting the Option 66/next-server address to the IP of the server rather than the Host name? If this cannot be done, can you setup of a DHCP reservation for your FOG Server so the hostname is always found?


  • Moderator

    @alpilles.info In your DHCP option it’s the server name or the ip that it’s specified ?



  • Hi, sure, i use ubuntu 14.04.1 LTS, i don’t have storage node only the fog server, the server is pingable, i have found that if i add the dns in FOG_PXE_IMAGE_DNSADDRESS it seem to work better (but i have never used this until now) also it’s written to turn off use sloopy name in this option but i don’t know where.
    It is very strange it work well until now (and like i said if the server is reboot it work for few days then this error come again), i don’t seem to have dns problem in the linux himself.
    Thanks


Log in to reply
 

386
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.