Strange error: Just booted my fog server got database installer / updater



  • Hi All,

    I just booted up my physical fog server, connected to it and got the “Database Schema installer/updater” screen. But I haven’t changed anything. I’ve left it untouched. I have loads of images on it, 120+. so I really don’t want to lose the database.

    I tried
    cd ~;mysqldump --allow-keywords -x -v fog > fogbackup.sql

    to back it up, but got the error

    – Connecting to localhost…
    mysqldump: Got error: 2002: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) when trying to connect
    root@fog1:~#

    This couldn’t have come at a worse time, as I’m supposed to deploy some images tonight, change them, image them up, then re image the servers back with another image.

    Could someone offer me a little help in backing up the database, and then fixing it.

    Thanks

    Julian


  • Moderator

    There might be relevant parts in that article, but it was last updated in 2011.

    I should re-write it… I’ll put it on my to-do list (I actually have a to-do list here).

    If you can get another HDD in, format it, mount it, etc, you could simply add a new storage node and point the path to your new HDD. Set your permissions on that new directory as 777 and it ought to work.


  • Moderator

    This post is deleted!


  • Thanks Wayne & Tom,

    I issued the “reboot” command to reboot the Fog server, hoping the SQL server would restart with it, but unfortunatley it didn’t.

    I restarted the SQL server, but it failed to initialize, I can’t remember the exact error, but it was basically not enough disk space.

    I was imaging up a load of servers last time, the disk was at 90%+ full. So I guess the SQL service didn’t have enough space to initialize. I deleted some images, which I’ve copied to a USB drive, rebooted the server, hey presto it all came up ok.

    First problem solved. :-)

    So it looks like I’m adding another 4TB disk to the server.

    I looked up this guide, is it still relevant to version 1.20?

    https://wiki.fogproject.org/wiki//index.php?title=Adding_Storage_to_a_FOG_Server

    Thanks again, your help is much apprechiated.

    Can this be marked as solved, to help the next person.

    Thanks

    Julian


  • Senior Developer

    What’s the output of

    sudo df -h
    

  • Moderator

    Try restarting MySQL.

    I think restarting MySQL might actually fix your issue.


Log in to reply
 

426
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.