Blacklist for duplicate MAC's



  • FOG-newbee here.
    I want to sysprep&clone a couple off (HP) Probook 430 & 450’s. When doing a “Quick Registration” of the first host, the service registers 2 MAC-addresses; when (quick) registering a second host the console tells me the host is already registered. The Probook consist of multiple network-capable devices (WAN/4G, Ethernet, WiFI, Bluetooth) and it looks like one of the device MAC-addresses isn’t unique. So i’d like to filter-out some of the discovered MAC-addresses.
    I found “FOG Settings -> FOG Service - Host Register -> FOG_QUICKREG_PENDING_MAC_FILTER”, but this doen’t seem to apply/solve my problem.

    Regards, Simon



  • Ah ok! Maybe this is default behaviour now? Tom will probably weigh in soon.

    I’ll upgrade to SVN later and see what happens myself.



  • It’s a SVN#3451 pull

    I don’t know what thee default are, but I think you are referring to this setting:

    fog.png



  • Are these hosts automatically having their pending mac addresses accepted? And are you on FOG 1.2.0?



  • The notebooks (quick) register 2 MAC’s. One is the (unique) ethernet-interface, the second (not unique) is another unknown device. I could look up the brand/type, but thats not the problem. I agree, it should not be possible to have duplicate MAC’s, but the fact is: I have. I did not lookup the device responsible, but i guess it is the WAN/4G Gobi (Qualcomm) interface/modem without a SIM (telco related), where the interface functions as some sort of un-numbered/loopback interface



  • Actually, I remember when I first started using FOG we had duplicate MAC issues. This was caused because I had “approved” pending MAC addresses - which included VMWare virtual networking adapters. These were all identical, since I had installed VMware Workstation on a base image and it had retained the same address on every PC.



  • We had duplicate MACs happen to many white box systems one year that had their motherboards replaced… all with 00’s or 88’s for a MAC.


  • Senior Developer

    Just so you’re all aware, I’ve been monitoring this thread waiting for more information.

    How can you have two systems with the same mac address? Are you using a shared nic between systems?


  • Moderator

    Bumping this thread…


  • Moderator

    I think that this is a developer question.

    Give them time, they will eventually get around to this thread (probably sooner than later).



  • Its a fresh pull: 3451


  • Moderator

    What version of FOG are you using? What distro of Linux and version?

    If you look in the cloud in the top left of the WEB UI, it’ll have a revision number.



  • Nothing special. Just boot and did a quick registration. The first host registers a “50:65:f3:nn:nn:nn” (which is the Ethernet-MAC) as hostMAC.hmPrimary=1 and “02:1e:10:1f:00:00” as hostMAC.hmPrimary=0.
    When the second host boots, the ipxe-menu tells me the host is not registered. Next I select “quick registration” and a “host already exists as …” somewhere in the following screens and the host is not registered in the FOG database/interface.


  • Moderator

    @kemperink said:

    I doubted myself and I double-checked. Both nodes claim “02:1e:10:1f:00:00”.
    It’s a clean, SVN trunk install and I only experimented with these 2 nodes (and a VM; it just boots quicker).
    Gonna try to work around the problem by blacklisting (modprobe.blacklist=modname1) the linux-module responsible.

    What method are you using to get the MAC addresses ?



  • I doubted myself and I double-checked. Both nodes claim “02:1e:10:1f:00:00”.
    It’s a clean, SVN trunk install and I only experimented with these 2 nodes (and a VM; it just boots quicker).
    Gonna try to work around the problem by blacklisting (modprobe.blacklist=modname1) the linux-module responsible.


  • Moderator

    @kemperink said:

    doen’t seem to apply/solve my

    I doubt you have two MACs that are the same.

    When quick registering or full registering, it only records the wired NIC.

    What’s more likely is somehow you’re DB got dirtied up.

    NORMALLY, I’d be able to search the forums and give you the exacto-answer for fixing this… but our forum’s searching feature is temporarily disabled due to issues.

    You might figure it out yourself though, look in your DB (like, connecting to MySQL via terminal) and look for hosts that have a MAC address set to zero, and just delete those. There are other things that could cause this, too.

    Maybe Tom could chime in?


Log in to reply
 

385
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.