TFTP Stopped Functioning



  • Yesterday everything was working fine without issue. Ubuntu came up and asked to install some updates, so I let it.

    Today when a client boots to FOG it gets an error “pxe-e32 tftp open timeout” and when I try and TFTP GET undionly.kpxe it says connection request failed.

    I checked 66 and 67 on the DHCP server and they are the same.

    I will post the results of ls -al /var/www/fog/service/ipxe and ls -ld /tftpboot in a moment, but they look to be correct to me.

    Thanks!



  • okay, it is fixed I had to restart both mysql and tftp.

    Thanks I am bookmarking the pages out of your signature.


  • Moderator

    Check out the troubleshooting article in my signature.



  • mj@fog-server:~$ sudo ls -al /var/www/fog/service/ipxe
    total 34192
    drwxr-xr-x 3 fog www-data 4096 May 14 15:41 .
    drwxr-xr-x 3 www-data www-data 4096 May 11 08:21 …
    -rw-r–r-- 1 fog www-data 1105 May 11 08:20 advanced.php
    -rw-r–r-- 1 fog www-data 44908 May 11 08:20 bg.png
    -rw-r–r-- 1 fog www-data 756 May 11 08:20 boot.php
    -rw-r–r-- 1 fog www-data 6169392 May 11 08:20 bzImage
    -rw-r–r-- 1 fog www-data 6170512 May 11 08:20 bzImage32
    -rw-r–r-- 1 fog www-data 234697 May 11 08:20 grub.exe
    drwxr-xr-x 2 root root 4096 May 14 15:51 hiren
    -rw-r–r-- 1 fog www-data 9577456 May 11 08:20 init_32.xz
    -rw-r–r-- 1 fog www-data 10914208 May 11 08:20 init.xz
    -rw-r–r-- 1 fog www-data 25340 May 11 08:20 memdisk
    -rw-r–r-- 1 fog www-data 1839104 May 11 08:20 memtest.bin

    mj@fog-server:~$ sudo ls -ld /tftpboot
    drwxr-xr-x 2 fog root 4096 May 11 08:25 /tftpboot

    mj@fog-server:~$ sudo ls -al /tftpboot
    total 2572
    drwxr-xr-x 2 fog root 4096 May 11 08:25 .
    drwxr-xr-x 25 root root 4096 May 11 08:25 …
    -rw-r–r-- 1 fog root 840 May 11 08:25 boot.txt
    -rw-r–r-- 1 root root 293 May 11 08:25 default.ipxe
    -rw-r–r-- 1 fog root 389009 May 11 08:25 ipxe.kkpxe
    -rw-r–r-- 1 fog root 389057 May 11 08:25 ipxe.kpxe
    -rw-r–r-- 1 fog root 388044 May 11 08:25 ipxe.krn
    -rw-r–r-- 1 fog root 389073 May 11 08:25 ipxe.pxe
    -rw-r–r-- 1 fog root 25340 May 11 08:25 memdisk
    -rw-r–r-- 1 fog root 16794 May 11 08:25 pxelinux.0.old
    -rw-r–r-- 1 fog root 165088 May 11 08:25 snponly.efi
    -rw-r–r-- 1 fog root 101989 May 11 08:25 undionly.kkpxe
    -rw-r–r-- 1 fog root 102037 May 11 08:25 undionly.kpxe
    -rw-r–r-- 1 fog root 382650 May 11 08:25 undionly.kpxe.INTEL
    -rw-r–r-- 1 fog root 102053 May 11 08:25 undionly.pxe
    -rw-r–r-- 1 fog root 147728 May 11 08:25 vesamenu.c32

    Also now that I am on the FOG machine locally, if I try and go to the management website it tells me the Database schema needs to be updated. I was able to open up and log into the same page without issue from my regular workstation until I logged onto the FOG server, now it too says the schema needs to be updated. Weird!!


Log in to reply
 

349
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.