1.2.0 issues- PXE boot loop, occasional freeze during iPXE initializing



  • Hi all,

    Environment: Fog 1.2.0 running on Ubuntu 14.04.2 server x64. Using latest standard Fog kernel, although I’ve tried the latest unofficial ones too (same behaviour).

    Problem 1: PXE bootloop on specific machine.

    We have some Lenovo ThinkCentre M72e desktops that I’m trying to register with Fog and image. The PXE booting process seems to go ok. The ‘iPXE initializing’ text appears, and then the text ‘configuring net0’ appears with the mak address of the interface. However, after this the machine reboots (rather than displaying the menu).

    I have noticed that the above takes a bit longer than I would have expected: my virtual machines on the same network go through the iPXE initializing and configuring net0 steps in a matter of seconds, but these desktops take a lot longer (and then don’t work anyway).

    Is there some timeout value that can be adjusted for this?
    Is it worth trying to use .kkpxe rather than the standard (and how do I make this change? In dhcp options?)

    Problem 2: occasional freeze during iPXE initializing

    We also have some Lenovo X1 Carbon ultrabooks, which use a USB ethernet dongle. These work with Fog fine most of the time, but occasionally when I do a PXE boot with them, the boot process seems to get stuck on the ‘iPXE initalizing’ stage. This seems to be fairly random, and in most cases I can simply reboot the machine and it will then work.

    Any thoughts on this one? I’m less concerned about Problem 2 as these machines are only plugged in to ethernet when I’m reimaging them, so staff aren’t impacted.

    Thanks in advance for your help

    [B]EDIT: Looks like using .kkpxe is the solution to my problem 1. Will this likely have any negative effects for other makes / models that were already working though?[/B]



  • @Wayne-Workman said:

    Just to make it clear, Secure Boot is currently required to be OFF to network boot with FOG. Can you provide us with a screen shot of the error ? You might need to take a video to capture the error, often times the errors are only displayed for fractions of a second. What happens if you try to boot using ipxe.efi ??

    At first, I didn’t know what you were talking about–the only efi file in my /tftpboot folder was snponly.efi. But then I read another suggestion from you elsewhere that maybe upgrading to trunk might help, so I tried that.

    And, lo, my /tftpboot doth overflow with efi files! So I tried ipxe.efi, and it WORKS.

    Also - see my old post below on the subject of using a USB dongle.

    That looks like really useful info once I get this host registered. Amazing.

    As you requested elsewhere, I will experiment with co-existing EFI and BIOS hosts using DD-WRT and see if I can’t contribute to the Wiki to pay it forward.


  • Moderator

    @jeffzimmm said:

    Hi Wayne, Thanks for all of your generous attention.

    I have tried every possible boot configuration.

    With kpxe: The farthest I get is with Legacy BIOS, Secureboot Off. It takes me to “Initializing Devices,” then beeps and reboots.

    With kkpxe: The farthese I get is with Legacy BIOS, Secureboot Off. It gets me as far as “Configuring (MAC address) …” Then times out and reboots.

    It looks just like the screencap in @hlcstudy 's post https://forums.fogproject.org/topic/5721/ipxe-intialising-devices-ok-then-reboots. The difference is that kkpxe is already in use and I get the same symptom.

    I note that you recommended in that thread to turn off firewalls. I thought I did that but will recheck.

    Just to make it clear, Secure Boot is currently required to be OFF to network boot with FOG. Can you provide us with a screen shot of the error ? You might need to take a video to capture the error, often times the errors are only displayed for fractions of a second. What happens if you try to boot using ipxe.efi ??

    Also - see my old post below on the subject of using a USB dongle.

    @Wayne-Workman said in Surface 3 and Fog 1.2:

    You have to specify that the NIC is a USB adapter with a kernel parameter on the host’s general page. YOu must set the ‘has_usb_nic=1’ kernel parameter.

    So, it should look like this:

    USB_Nic.png

    But, I believe that Surface 3s are UEFI, so you will need to use an .efi boot file. All the boot files available are in the /tftpboot directory, I suggest trying ipxe.efi first.

    Past these things, you will need to upgrade to trunk, I believe, for better Windows Tablet support. There’s been a lot of work done in this area in FOG Trunk. You will still need to use the .efi files and the kernel arguments with fog trunk, but you might have better odds with getting it working and getting all the partitions to recognize correctly. Here’s info on FOG Trunk: https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    Please report your findings - this is how you give back to the fog project - by reporting back with details.



  • Hi Wayne, Thanks for all of your generous attention.

    I have tried every possible boot configuration.

    With kpxe: The farthest I get is with Legacy BIOS, Secureboot Off. It takes me to “Initializing Devices,” then beeps and reboots.

    With kkpxe: The farthese I get is with Legacy BIOS, Secureboot Off. It gets me as far as “Configuring (MAC address) …” Then times out and reboots.

    It looks just like the screencap in @hlcstudy 's post https://forums.fogproject.org/topic/5721/ipxe-intialising-devices-ok-then-reboots. The difference is that kkpxe is already in use and I get the same symptom.

    I note that you recommended in that thread to turn off firewalls. I thought I did that but will recheck.


  • Moderator

    @jeffzimmm said:

    Dell XPS 13

    Can you look in the Firmware settings to see if this is booting via UEFI or BIOS? And can you verify if Secure Boot in the Firmware is on or off?



  • I would just like to note that I have the same exact “Problem 1” with an almost identical configuration, with the exception that my host is a Dell XPS 13 (also with a USB dongle).

    undionly.kkpxe did not solve it.


  • Moderator

    [quote=“mr626, post: 47238, member: 523”]

    Looks like using .kkpxe is the solution to my problem 1. Will this likely have any negative effects for other makes / models that were already working though?

    Nope. undionly.kkpxe will work with anything that works with undionly.kpxe.


Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.