PXE boot menu then black screen

  • I have an Ubuntu 12.04 server with Fog 1.2.0 on it. I just ran the SVN to 3387 version as well. This is all new. When a host goes to boot PXE it gets to the menu screen. I select perform full host registration and inventory. Then nothing happens just a black screen. I have left it like that for 30 minutes and tried several times on many different hosts. When I tried from a vm I got:

    tftp://x.x.x.x/default.ipxe… ok
    [url]http://x.x.x.x/fog/service/ipxe/boot.php[/url]… ok
    /bzimage… No such file or directory (http:ipxe.org/2d0c613b)

    any help on how to get past this point?

    I have went through so many of these forums today and nothing gets me past this point. Thanks for your time.

  • sweet that kkpxe did the trick somehow. I am getting everything connected and running now thanks for the help and good work with fog trunk versions

  • Woot woot

  • Thinkstation S20 works fine with undionly.kkpxe and AHCI set in the bios. Work with last svn up and down.

  • They are just suggestions, things I’ve had luck with for Lenovos.

    Changing your boot file and changing your kernel is really easy to do. (easier in trunk)

  • We have M73, M81 etc desktops. Our laptops are from the B560/B590 all the way to E550’s.

    So the .kkpx is better for you on lenovos than the .kpxe?

    Do I need to revert my kernel from 4.0.2 all the way back to 3.18.3?

  • For the record, I run fog inside Hyper-V, and the only kind of image I upload is from physical machines.

    I use undionly.kkpxe because Lenovo desktops have issues.

    For some Lenovos, I’ve had success with kernel 3.18.3 x86_x64, and I use the trunk version of fog (the latest revisions).

    What are the exact models of Lenovos you’re using? Have you checked our “Working Hardware” and “Problematic Hardware” lists?

  • Also When I do a quick image and select the OS it goes to a black blank screen with a flashing cursor. When I reboot to PXE I get a bzimage error. I have to go into the GUI and delete the task out. If i set an active task in the GUI to reimage it I get the same bzimage error. This is all so confusing and a mess. Fix one issue to bounce into another.

  • OK that svn update seems to have fixed me getting to image. The image went through but I get the blue screen of death after it starts windows when its done. Maybe I just have a bad image. I still get that same error that I listed above except now with new 3396 it goes through and images. I am re uploading an image from an actual computer this time, instead of a VM see if I get a good image that way.

  • no there is no proxy

  • saltlife3122, are you behind a proxy?

  • Developer

    sounds like Tom just released a new version that’s targeted at problematic Lenovos [url]http://fogproject.org/forum/threads/hardware-currently-working-with-fog-v1-x-x.10685/page-4#post-47392[/url]

  • no the bzimage was only an issue when I perform a registration and select yes to image I get the bzimage error. The above error I just posted is when I try to image from fog on a good image or so I thought. It fails out of the image task at that point then says it completed and restarts.

  • Developer

    are you getting bzimage errors, or does it go into the imaging task and fail out? those are entirely different things

  • Then it just says task complete and reboots. Never images anything

  • I have registered host from PXE and the GUI. I uploaded a fresh image into the server. It see’s that image and you can see it in the GUI and command line. I am getting a file issue it happens to quick when I image I get all the way through to where it picks a node.

    I get this
    *Using Hard disk: /dev/sda
    *Erasing Current MBR/GPI Tables…Done
    awk: fatal: cannot open file '/images/WIN732bbaseimage/d1.minimum.par
    r reading (No such file or directory)

  • Developer

    how are you registering your hosts? from the pxe boot menu, or by entering the mac address into the web gui?

  • Developer

    have you verified that the bzImage, bzImage32, init.xz, and init_32.xz files downloaded successfully?

  • Seemed like from all the installs no one had this many problems getting pxe to boot. So when I register and schedule the host to image it gives me that bzimage error. But all the new computers will register fine but imaging won’t happen because of this error.

  • I already am svn at 3395. I can get hosts to register once. Now when I go back into the pxe boot I get a bzimage error could not boot etc.