Starting FOG Snapin Replicator Server...Failed!



  • Hello!

    I tried to upgrade my storage node from revision 3090 to the revision 3385.
    Tried it a few times and every time it failed with.

    Starting FOG Snapin Replicator Server...Failed!
    

    and sometimes the error comes for the other services. o_O
    File/Directory permissions are correct.
    SQL access works fine and the credentials are correct.
    Have reverted back to revision 3090 and there everything works fine.

    My fog server is in a virtualbox on debian
    My storage node is on centos server 6.6
    Anyone have an idea?
    Thanks,
    Albatros



  • I pulled the updates with svn from the trunk directory and started the installer from the trunk/bin directory.


  • Developer

    @Albatros, post: 47248, member: 16710 said:

    I was in the trunk/bin directory, where I run the installfog.sh file.

    the way that svn works is that it only updates files and sub-directories of the directory you’re in. you need to be in trunk, not trunk/bin, to update the files correctly



  • Well did run it again, after an restart and now it works. Have no clue what the cause was, but this is now fixed.



  • @Tom Elliott, post: 47188, member: 7271 said:

    when you updated to 3385, where you in the root of your svn?

    (e.g.)
    /opt/trunk vs. /opt/trunk/packages/web

    I was in the trunk/bin directory, where I run the installfog.sh file.


  • Senior Developer

    when you updated to 3385, where you in the root of your svn?

    (e.g.)
    /opt/trunk vs. /opt/trunk/packages/web


Log in to reply
 

478
Online

38926
Users

10692
Topics

101459
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.