Hparm ioctl



  • I have a fog server set up on my laptop. I have used this exact laptop to image about 20 Latitide D600 several months ago. Now I need to deploy an image to another 5 or so I missed. When I try either a quick or full host registration I get the following error message “hdparm: ioctl 0x304 failed: Inappropriate ioctl for device”. While I had a similar issue with another fog server at another location and tried updating my dhparm in my os it had no effect. I was wondering if you could manually update your hdparm within the pxelinux.0 This is an issue I have seen with several machines in our School District and as such must use multiple imaging solutions which i would like to do away with.


  • Senior Developer

    I’ve found that any time I’ve had the hdparm: ioctl 0x304 failed: Inappropriate ioctl for device issue, it’s not necessarily a driver issue, though it could very well be one. However, check your PXE file.

    Make sure that the web part of the pxe server: does not look like this:
    10.0.7.1/fog

    Make sure you add the trailing slash otherwise you’ll see this issue.

    On the same note, make sure your FOG Settings Page :
    FOG Configuration (? Circle Icon) -> FOG Settings -> Web Server section -> Web Root also has the trailing slash as this is used to create the boot file for the hosts when tasks are setup.

    Hopefully this helps.
    [COLOR=#000000]10.0.7.1/fog/[/COLOR]


  • group:cid:11:privileges:mods:members

    Thanks for detailing your findings. I don’t have the resources to install .33 right now so I will set this aside for the moment.



  • [quote=“altitudehack, post: 14115, member: 23”]Hey Sebastian. Thanks for linking to the other thread. What was the solution? Using a different FOG server? What is the difference between the two?[/quote]

    No solution until now.

    1. 0.33 Beta, Ubuntu Server 12.10 x86
    2. 0.33 Beta, Ubuntu LTS 12.04.2 x64

    The second server does not work until now, installed out of SVN from 12. July. I have done everything like the first machine, configuration etc.

    I tried to change the kernel, downgrade, upgrade, reinstall, nothing seems to work until now!


  • group:cid:11:privileges:mods:members

    Hey Sebastian. Thanks for linking to the other thread. What was the solution? Using a different FOG server? What is the difference between the two?



  • Had nearly the same problem here:
    [url]http://fogproject.org/forum/threads/host-registration-hdparm-ioctl-0x304-failed-inappropriate-ioctl-for-device.4494/[/url]

    No solution until now.

    Tried to update or degrade the kernel, tested all SATA modes and it is remarkable that on the same computer with different FOG versions and different Ubuntu version I got one time no problems and the other I got that error.


  • Developer

    Currently I’d start by harvesting the drivers required and adding them in.

    I.E. Video card, NIC, any kind of ATA or RAID adapters, basically anything that FOG is going to NEED in order to process the host.

    You can use older KS kernels to, you don’t JUST have to use the recent one, matter of factly some users find that the older version of the kernel works where as the latest does not.


  • group:cid:11:privileges:mods:members

    Thanks for the response, Jaymes. I don’t see any current KS kernels in the update list. Is there an external source for them?
    How would you go about discovering the correct driver to embed?


  • Developer

    if there is no way to “fake” the sata controller, use the custom kernel guide to include the SCSI controller drivers that Proxmox uses. You may try the kitchen sink kernel before you compile your own, it will normally take care of most issues. I found with VMWare ESXi even including the drivers did not help, but I could upload just a slow speeds. If your drive can’t be found, your kernel is missing the drivers necessary.


  • group:cid:11:privileges:mods:members

    I’m seeing “ioctl 0x304 failed: Inappropriate ioctl for device” while trying to register a virtual system running on Proxmox 3.0. I suspect it’s having an issue with the “SCSI Controller Type”. I don’t see a way to fake a standard SATA controller.



  • Try upgrading your Kernel. I was just having the same issue, but I was unable to image/register any host. Also check /tftpboot/pxelinux.cfg/default and make sure all the web=“your web interface address”



  • i meant like like the output of uname -r, distro ect



  • Running 0.32 with no issues on the default kernel.



  • Good call I forgot to check that.

    Also what version of fog are you using on the 755 and what version of linux ect? I have sucessfully done a 755 without issues



  • The newer dells have ATA mode, and two others, one standard, and one which is a custom intel raid mode. I would start by checking the controller mode in bios and make sure it is on ATA not ACHI or Raid.



  • Hi,

    I have same issue with Dell optiplex 755 i treid several option like degrading kernel version
    any idea how to fix this ?
    please advice
    Thanks


Log in to reply
 

368
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.