Webinterface doens't show any hosts under host management



  • Hi!

    I updated to fog 1.2.0. Now i have the problem that I can’t see my hosts anymore in the webinterface at host management. It doens’t show any hosts if i search for hosts either. Under reports management -> host list my hosts are listed. In the mysql database under fog -> hosts my hosts are listed too.
    Im using Debian Wheezy 7.8.

    Thanks for your help.

    Stefan



  • After updating to subversion 3356 the problem is solved.
    Thanks a lot for you help!

    Stefan



  • There might not have been any DB changes from 1.1.2 to 1.2.0 Although I’m not sure.
    If there are no changes, you won’t be presented with anything to update on the Web Interface.

    Lets verify the data in your DB.
    On your FOG server:

    [CODE]mysql -u root fog
    SELECT * FROM hosts;[/CODE]

    You should see data about your hosts… let us know.



  • I updated from 1.1.2 to 1.2.0.
    I reinstalled MySQL (apt-get install --reinstall mysql-server mysql-server-5.5).
    After that i tried to reinstall fog using /opt/fog/bin/./installfog.sh.
    I couldn’t update the database schema. When i get the message to go to [url]http://172.30.40.25/fog/management[/url] I have no option to update the database schema.
    It shows just the normal webinterface. How can I update the database schema?
    It still doens’t show hosts. So reinstalling MySQL didn’t help.
    I have about 450 host registered.



  • Permissions on the web files are all good.

    All of these errors you’re seeing in your Apache logs, those are MySQL / DB related.

    What version of FOG did you update from?

    Did you update your database schema via the web interface as the installer instructed?

    Can you try to re-install MySQL ?

    How many hosts do you have registered (roughly)?



  • Re-run the installer didn’t help. Here is the output of ls -laR /var/www/fog

    [url="/_imported_xf_attachments/1/1943_output.txt?:"]output.txt[/url]



  • I think your /var/www/fog/ permissions are either messed up, or some files in there don’t exist… which is quite odd…

    Can you run this?
    [CODE]ls -laR /var/www/fog[/CODE]

    Please put the output into a text file and attach that here.

    have you tried to just re-run your installer?



  • Here are the log files…

    [url="/_imported_xf_attachments/1/1936_foginstall.log.txt?:"]foginstall.log.txt[/url][url="/_imported_xf_attachments/1/1937_error.log.txt?:"]error.log.txt[/url]



  • Can you post your installation log? Look in Tom’s signature above for the location ^^^


  • Senior Developer

    What, exactly, steps did you do to upgrade?

    The installers don’t delete data from the database except in regards to a few specific tables, and even then it’s not deleting but rather moving data to other tables.



  • I already tried that. I didn’t work. Deleting the cash of the browser didn’t help either. I tried Internet Explorer and Firefox.


  • Senior Developer

    The hosts were not deleted by fog in any way. Can you try hard refreshing the page? Shift+F5


 

536
Online

5.4k
Users

12.6k
Topics

118.9k
Posts