FTP Gotcha on Ubuntu (Should Be Added To The Wiki?)



  • Hey guys,

    I just wanted to pass on something I had to work through with regards to uploading an image. I was getting the infamous “Can’t rename/move Permission Denied” messages on the client after it had finished imaging. Most posts tell you to ensure the FTP passwords are all set corretcy in the various PHP files, make sure permissions are set correctly on the /images folder, etc. None of this worked for me.

    I have a vanilla Ubuntu 14.04 server running only FOG. When I logged in using the fog user with an SCP client over SSH, I could read/write/modify/delete everything I expected to be able to. But, when I used and FTP client with the same account, I couldn’t even modify the fog user’s home directory. What I discovered was that in my /etc/vsftpd.conf file, [CODE]write_enable=YES[/CODE] was commented out, so therefor no FTP users could modify anything. After I uncommented this and restarted the service, I was able to get my image to finally upload

    Hope this can help someone else out because I didn’t se this as a solution anywhere else


  • Moderator

    [quote=“SouperGrover, post: 46109, member: 27066”]Hey guys,

    I just wanted to pass on something I had to work through with regards to uploading an image. I was getting the infamous “Can’t rename/move Permission Denied” messages on the client after it had finished imaging. Most posts tell you to ensure the FTP passwords are all set corretcy in the various PHP files, make sure permissions are set correctly on the /images folder, etc. None of this worked for me.

    I have a vanilla Ubuntu 14.04 server running only FOG. When I logged in using the fog user with an SCP client over SSH, I could read/write/modify/delete everything I expected to be able to. But, when I used and FTP client with the same account, I couldn’t even modify the fog user’s home directory. What I discovered was that in my /etc/vsftpd.conf file, [CODE]write_enable=YES[/CODE] was commented out, so therefor no FTP users could modify anything. After I uncommented this and restarted the service, I was able to get my image to finally upload

    Hope this can help someone else out because I didn’t se this as a solution anywhere else[/quote]

    You’re problem and solution have been documented here: [url]http://fogproject.org/wiki/index.php/Troubleshoot_FTP#Images_stuck_in_.2Fimages.2Fdev[/url]



  • This server actually started out as Ubuntu 12.04 I had some issues prior to getting this far, decided to upgrade the server, and didn’t get the image upload to even start until after the server was on 14.04. So, I’m not sure if that setting was in place from Ubuntu 12.04 or not. One of he Wiki pages advises you to backup any changes made to vsftpd.conf before doing a FOG upgrade. What modifications to the file does it do?


  • Senior Developer

    Normally, there’s a Priv Sock issue which is auto corrected for, now, in the installer. I’m not aware of write_enable.


  • Moderator

    After a quick search in the WiKi for vsftpd.conf with only two hits, I agree that there should be more documentation about this.

    I’ll work on adding examples for FTP configuration into the WiKi.


Log in to reply
 

376
Online

39198
Users

10850
Topics

103281
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.