Issue with FOG and taking a client snapshot



  • Hi guys

    I have a bit of a problem. It seems like one of my computers is stuck in a loop when trying to upload an image.

    I have deleted the task from Fog, yet still when I boot the device using the network, it keeps automatically trying to upload an image to the Fog server.

    I can’t for the life of me figure out where it is reading that request from, as it isnt reading it from the FOG gui - so I imagine there is some cron job set up.

    Any ideas?

    Thanks!


  • Developer

    James, it sounds like you are having permission issues.

    First, it was unable to remove the PXE file, now it cannot move image files?

    The error that said it was unable to move the file told you WHY it couldn’t move the file. What was the full error message?

    To fix this one
    [LIST=1]
    []I would power off the uploading machine
    [
    ]Cancel the task in FOG
    []Manually move the image
    [
    ]Find and fix your system issues
    [*]Life goes on :)
    [/LIST]



  • Hi

    Thanks - /images/NAME doesnt exist, only the name of the one that was successfully created.
    I even tried manually creating /images/NAME and setting the permissions, but still it failed :/


  • Developer

    can you check to see if NAME is in /images on the server? if yes then delete the NAME in /image and delete /images/dev/MAC then try upload image again.



  • Thanks Marcus

    That worked a treat!

    Got another problem…

    I keep getting “unable to move /images/dev/MAC to /images/NAME” - i’ve run the permissions fix in your WiKi but still it happens.
    It ONLY does it on one machine. The other machine was fine when I did the image.

    I’ve deleted the host, deleted the image, deleted the task and tried again.

    :/



  • navigate to /tftpboot/pxelinux.cfg and make sure there are no mac addresses in this list. Majority of the time deleting the task will fix the issue. But sometimes the instructions are left in this directory via a mac address.


Log in to reply
 

386
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.