Multicasting



  • I’m back on the hunt for a solution to multicasting. The last time I really looked into this was last summer and I gave up, but now our imaging projects are coming up again.

    First things first: I’m currently testing on a new install of Ubuntu 12.04 and using the latest fog SVN 3264. The problem I’m seeing is clients get to the please wait screen and then never go past that.

    I’m working through this wiki: [url]http://fogproject.org/wiki/index.php?title=Troubleshooting_a_multicast[/url]
    Testing 1 client is successful
    Testing 2 clients is successful
    Under something else to try, that fails and I see this on the server:

    root@fogtesting:~/svn/trunk/bin# gunzip -c “/images/U160SGEJuly2014” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 9000 --interface eth0 --half-duplex --ttl 32
    Udp-sender 20120424
    Using mcast address 234.162.70.30
    UDP sender for (stdin) at 10.162.70.30 on eth0
    Broadcasting control to 224.0.0.1
    New connection from 10.162.3.33 (#0) 00000009
    Ready. Press any key to start sending data.
    New connection from 10.162.3.38 (#1) 00000009
    Ready. Press any key to start sending data.
    Starting transfer: 00000009
    Timeout notAnswered=[0,1] notReady=[0,1] nrAns=0 nrRead=0 nrPart=2 avg=8362
    Timeout notAnswered=[0,1] notReady=[0,1] nrAns=0 nrRead=0 nrPart=2 avg=8362

    It looks like the clients are communicating with the server but the data just doesn’t send correctly. I’d like to think multicasting is configured correctly on our network because we have other multicast applications working properly.

    Thoughts?


  • Testers


  • Developer

    [quote=“Wayne Workman, post: 45847, member: 28155”]Can you elaborate on this? I’m interested in it.

    I’ve yet to even use snapins, going to have to sit down and mess with it eventually.[/quote]

    the Dell CCTK Configuration Wizard allows you to create scripts for changing bios settings


  • Moderator

    [quote=“Junkhacker, post: 45846, member: 21583”]we have snapins that we can run to change the boot order for most of our dells[/quote]

    Can you elaborate on this? I’m interested in it.

    I’ve yet to even use snapins, going to have to sit down and mess with it eventually.


  • Developer

    we have snapins that we can run to change the boot order for most of our dells



  • Hmm, that’s a possibility. I’ll keep that in mind for the summer when we go touch every station.


  • Moderator

    [quote=“Ben Warfield, post: 45839, member: 17746”]Ha. I’d love to. Long explanation there though, totally unrelated to fog. We have teachers who use netop vision to wake up their computer labs in the morning. They complained about the extra time the pxe boot added to startup. I know, all of 15 seconds at most, but that’s a battle I wasn’t willing to fight. So 90% of our labs are set to boot right to the hard disk when they get the magic packet.[/quote]

    You can turn off the FOG menu… that’ll cut down on the time.



  • Ha. I’d love to. Long explanation there though, totally unrelated to fog. We have teachers who use netop vision to wake up their computer labs in the morning. They complained about the extra time the pxe boot added to startup. I know, all of 15 seconds at most, but that’s a battle I wasn’t willing to fight. So 90% of our labs are set to boot right to the hard disk when they get the magic packet.


  • Developer

    [quote=“Ben Warfield, post: 45835, member: 17746”]I like this idea. Usually when I’m imaging, I start the task and go PXE boot the machine(s) within a few minutes - maybe an hour or 2 at most. Maybe there could be a custom TTL for users who would want a longer timeframe?[/quote]

    why not let the fog server wake them up with wake on lan?



  • This post is deleted!


  • [QUOTE=Wayne Workman]I remember another thread about making tasks have a TTL sort of feature… Has that been implemented? If the default TTL is maybe 24 hours, then this guy wouldn’t have had the multicast issues the next day… it’d just resolve itself because the old tasks would get deleted.[/QUOTE]

    I like this idea. Usually when I’m imaging, I start the task and go PXE boot the machine(s) within a few minutes - maybe an hour or 2 at most. Maybe there could be a custom TTL for users who would want a longer timeframe?


  • Moderator

    [quote=“Tom Elliott, post: 45825, member: 7271”]Then I’d recommend trying to truncate the multicastSessions and multicastSessionsAssoc tables. Also clean up any left over taskings:

    [code]truncate table multicastSessions;
    truncate table multicastSessionsAssoc;
    delete from tasks where taskTypeID=‘8’;[/code][/quote]

    I remember another thread about making tasks have a TTL sort of feature… Has that been implemented? If the default TTL is maybe 24 hours, then this guy wouldn’t have had the multicast issues the next day… it’d just resolve itself because the old tasks would get deleted.



  • Ahh it was the leftover tasking that was holding me back. It’s working now and I’m currently watching 4 machines being multicasted to. Thanks again everyone.


  • Senior Developer

    Then I’d recommend trying to truncate the multicastSessions and multicastSessionsAssoc tables. Also clean up any left over taskings:

    [code]truncate table multicastSessions;
    truncate table multicastSessionsAssoc;
    delete from tasks where taskTypeID=‘8’;[/code]



  • Ahh sorry, I wasn’t quite clear.

    It is not working. When I click multicast for a group, I see the tasks for the individual machines show up under active tasks. But nothing appears under Active Multicast Tasks.


  • Senior Developer

    I guess I’m not understanding what the issue is. Is it not working, or you’re just worried about the errors?



  • Hmm, we’re getting closer. I only get the second error now:

    [Mon Apr 20 11:11:44 2015] [error] [client 10.162.3.26] PHP Warning: Invalid argument supplied for foreach() in /var/www/fog/lib/fog/Host.class.php on line 978, referer: [url]http://10.162.1.212/fog/management/index.php?node=group&sub=deploy&id=84&type=8[/url]

    Edit: Sorry, still getting both errors. I had my log scrolled down too far to see the first ones.


  • Moderator

    Maybe try to re-create that group? Remove the computers from it, delete the group, then re-create and re-add computers?



  • I’ve got something else weird going on now. I’m on SVN 3275 and when I try to multicast to a group, I see these errors in apache:

    [Mon Apr 20 10:48:27 2015] [error] [client 10.162.3.26] PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/fog/lib/pages/TaskManagementPage.class.php on line 344, referer: [url]http://10.162.1.212/fog/management/index.php?node=tasks&sub=listgroups[/url]

    [Mon Apr 20 10:48:27 2015] [error] [client 10.162.3.26] PHP Warning: Invalid argument supplied for foreach() in /var/www/fog/lib/fog/Host.class.php on line 978, referer: [url]http://10.162.1.212/fog/management/index.php?node=tasks&sub=listgroups[/url]

    This is an issue that seems to be related just to my installation of fog and our database, as it works correctly on a fresh install of the SVN. I’m not sure what I should be asking now: Is there a way to check for invalid data, or what would be a good troubleshooting step? At this point I don’t think multicasting itself is the issue (again, because it works on a fresh install)



  • That fixed it! Thank you very much. I ended up on SVN 3267.


Log in to reply
 

431
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.