Fog 1.2.0 Kernal Errors



  • Good morning all

    I have recently been having issues with kernel panic messages appearing when I look to do a bypass host registration image from the pxe boot menu. I have downloaded several different kernals and updated the pxe config to point to the different downloaded config and still just getting the Kernal panic message, I have left it a good 5-10 minutes and it just stays on that error. The machine in question is Dell inspiron 6440.

    Indecently the whole kernel side of play on the new Fog server is slightly different i started to get my head around it in the previous version and know its a bit of trial and error.

    Hope i have supplied enough info but would be keen to hear from anybody on this is issues



  • I have had to accept defeat for the time being and I have gone back to Fog 0.32 to get me around the Kernel issues. It has caused a back log of stations needing to be imaged.

    Can I ask if anyone has any tutorials or links I can read up on to see about compiling fog kernels for 1.2.0, im a complete Ubuntu numb nuts and struggle with getting my head around the commands etc.

    Thanks all


  • Senior Developer

    The esas2r issue means you’re probably using the 3.14.2 (that shipped with 1.2.0) kernel.

    All of the TomElliott kernels are MASS NIC kernels.



  • I have just tried a Dell Inspiron 15r and I am getting the same problem with Kernal panic, I have downloaded from the Fog management page a new kernel but still know avail. I apologies if I’m being a donkey but I cant seem to get my head around the new kernel scenario. Is there a mass network driver kernel I can download? part of the message says
    "esas2r: driver will not be loaded because no ATTO esas2r devices were found"

    any help would be ideal but these are laptops that I have had no issues with on 0.32 version.



  • Hi tom

    im using version 1.2.0

    I will check the log files and report accordingly. I have gone on the forums etc and i also tried your wegpage kernel but still no fix, but it could be that im just being stupid and not understanding how to create the kernel.


  • Senior Developer

    What version of fog are you using?


Log in to reply
 

349
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.