TFTP issues



  • A while back, my fog server went down. Linux did updates, then the server stopped working. I thought, alright, ill reload ubuntu and turn off auto update. I have since tried to load fog about 50 times with no success, using every version of linux i can find. The major problem I have is tftp. I cannot connect to tftp from the windows command line. I can from within linux.

    I have gone through every threat on tftp, i have done everything suggest, permissions, etc. I cannot get it to work. Any suggestions?


  • Moderator

    The file is here: /etc/dhcp/dhcpd.conf

    Here is my reference: http://askubuntu.com/questions/221329/how-do-i-configure-dhcpd

    If FOG has configured DHCP for itself, it’s almost surely correct. Also, if FOG is doing DHCP, you only need option 67 configured for it, which should already be done.

    Please do a TCP dump on your FOG server.

    Taken from another post by Uncle Frank:

    sudo tcpdump -w issue.pcap -i eth0
    

    You might need to change the interface name in the above command, seems like I have never had an interface named eth0 in Linux… This command will list all available interfaces. Pick the right one.

    ip link show
    

    Run the above capture command on the FOG machine, then start the remote target host. Wait till it fails, then stop tcpdump (ctrl+c), transfer the PCAP file to your PC and examine it using wireshark. After the capture is completed, please use the MAC address of the target host as the filter for sender & receiver. This address will filter out ALL traffic that isn’t coming from or going to the target client.

    Example Filter (change the MAC addresses):

    eth.dst == 00:0C:CC:76:4E:07 || eth.src==00:0C:CC:76:4E:07
    

    Please also post this PCAP file so we can look at it and see what’s going on. And if you don’t filter the file for us, we will need the target host’s MAC as well so we can filter it.

    #LetsMakeScripts



  • Fog is doing DHCP. I believe options 66 and 67 are set, but how do I look? I recall there being some file with that info but i forget where


  • Moderator

    What is running DHCP? Have you set options 66 and 67 ?



  • I just did that, reset, and i am getting the same message. I have also checked the tftpd-hpa file, and it is identical to yours

    I have also disabled the firewall in ubuntu, changed permissions to 777, made sure iptables was correct


  • Moderator

    This post is deleted!

  • Moderator

    Can you try to create that file, as seen here: http://fogproject.org/wiki/index.php/Troubleshoot_TFTP#TFTP_Service

    After you’re done, restart the TFTP service and try again from windows.
    Let us know…

    Also, feel free to read around in that WiKi page… there’s a lot of stuff in there.

    Also,

    What is the output of this?

    cat /etc/default/tftpd-hpa
    
    

    the /etc/default/tftpd-hpa might look like this:

    # /etc/default/tftpd-hpa
    # FOG Modified version
    TFTP_USERNAME="root"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="-s"
    


  • no such file or directory


  • Moderator

    What is the output of:

    cat /etc/xinetd.d/tftp
    


  • I have disbaled the firewall on the server, now it seems to work. ONly one issue, I now get “No such fire or directory” error when trying to boot


  • Moderator

    Also, you might wanna check this out: http://fogproject.org/wiki/index.php/Troubleshoot_TFTP

    I just made that, as this problem comes up so often.


  • Moderator

    It’ll simplify testing for you…
    If it works in Windows, then it will work with pulling a boot file from TFTP.

    Also, it’s not necessary to do this on your server. Just do it from a windows client.



  • would this make a difference for PXE? I mean, I am running the test because the PXE boot getrs stuck at “TFTP…”

    i opened port 69 and am still having the issue


  • Moderator

    Please temporarily disable your windows firewall, and test again. If it works, you need to punch a hole out for port 69 inbound and outbound.

    ""



  • Ubutnu 14.04 Desktop x64. I’ve tried older versions, and server versions as well

    ""


  • Moderator

    We can help, we deal with this all the time.

    What distro of Linux and what version are you currently using?
    What version of FOG (or what revision, look at the cloud in the top left corner of the log on page) ?

    Please post your installation log. It’s here: /var/log/foginstall.log

    And, if you can,
    Give us a screen shot of how you use the Command Prompt in windows to connect to the /tftpboot directory via tftp.


Log in to reply
 

475
Online

38710
Users

10537
Topics

99776
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.