Unable to move and rename Images (NAS Implementation)



  • Hello,
    I recently setup fog on our windows network, on a debian box. My fog images are being stored on an Iomega Storcenter NAS that supports NFS and FTP.

    When imaging a host, everything goes fine until it tries to move and rename the image. The host spits out an error about being unable to move from /mnt/pools/A/A0/fog/dev to /mnt/pools/A/A0/fog. The .mntcheck files are present, there is a fog ftp account setup, and as far as I can tell the credentials are correct. The NAS runs pro ftpd 1.3.1 server. I have no problems connecting via ftp from my fog server to the NAS.

    One thing that was interesting, I tried to rename the files manually from the fog server using the debian GUI (not the terminal). This process errors in Debian but when I leave the directory, and return to it the files are renamed. I know that I can manually rename and move the files, but I really do not want to do things this way. I’ve kinda of hit a wall. Thanks in advance!


  • Banned

    This post is deleted!


  • [S]see attached image.[/S] Well it failed to attach a file.

    Anyway, mine looks like this:
    Host is set to Windows7.

    Image Name: Windows 7
    <No Description>
    Storage Group: default
    ImageType: Multiple Partition Image - Single Disk.

    Do not forget to run sysprep before you try to image.



  • I’m having the same issue. What ‘Host OS’ do you have under host management ? Also, what ‘Image Type’ do you have under image management ?

    I see this in some code which seems to be hard setting the image type to multiple partition, single disk for Windows 7.

    fog_0.32\src\buildroot\package\customize\fog\scripts\bin\fog

    [PHP]if [ “$osid” == “5” ]
    then
    imgType=“mps”;
    fi
    [/PHP]



  • Adam’s Quote from edugeek: you can set the user ID in the NAS…(see screenshot)[ATTACH=full]75[/ATTACH]
    The umask for my share is: in fact the default… (0022) I will look into that next.

    I imaged another machine and got the same message.

    “unable to move /nfs/images/dev to /nfs/images”

    Its strange because I can FTP with my ftp client and pass the command to move the files… there is no error there.

    I have a feeling that if we keep poking around, we will finally have that “Ah HAH!” moment we have been waiting for.

    [url="/_imported_xf_attachments/0/75_foguser.jpg?:"]foguser.jpg[/url]



  • EDIT:
    I got it back again… apparently, I was attempting to mount to
    192.168.1.244:/mnt/pools/A/A0/images (images is my share on the NAS)

    It Worked when I put it in like this:
    192.168.1.244:/nfs/images

    Now: I had disabled FTP on my NAS while troubleshooting and I got the Failed to connect to FTP… so I enabled FTP and the message instantly changed…

    Now, according to “Seperate NFS server tutorial” I have added an @ to the beggining of ftp on line 133 of /var/www/fog/service/Post_Stage2.php

    Now I just have to wait for it to image another machine before I know for certain… Will post back



  • This from edugeek:
    [I][SIZE=13px][COLOR=#333333][FONT=Verdana]“I think you would have to look for a umask setting on the NAS box, or look to try and match the owners id number with the id number for the FOG user on the server.” [/FONT][/COLOR][/SIZE][/I][SIZE=13px][COLOR=#333333]I don’t believe our NAS has a umask setting. Would you know how to track down the resource numbers?[/COLOR][/SIZE]



  • Glad I could be of help, I just tried changing the storage ftp username domain\user, but that did not help me either, actually set me farther back…

    Yeah I did not know what chroot is. For further communications, assume that you are talking to a linux noob (because I am).



  • However, I am in the same boat as you know, failed to move the images out of the /dev/ directory.
    [B]“unable to move from /mnt/pools/A/A0/fog/dev to /mnt/pools/A/A0/fog”[/B]
    [B][/B]
    I Just noticed that when I log into terminal as fog on my fog-server, I am chrooted* to the /images/dev directory, this may be what we are looking for. I will dig around some more and post my findings.

    [SIZE=2]*If you are not familiar, chrooted means that the user is “jailed” to the single directory (like a prisoner).[/SIZE]



  • Not sure about if you would have to join your server to AD, but you can, I have a few linux servers joined to the domain… there are a few ways to do this, find the one that works best for you and your distro. [URL='http://linuxgazette.net/105/price.html’]Here’s an offsite link that shows you how to use samba to join the domain. [/URL](I joined my others to domain within WEBMIN)[URL=‘http://linuxgazette.net/105/price.html’][/URL][URL='http://linuxgazette.net/105/price.html’] [/URL] You should not need to re-install fog after this. It should not matter.[URL=‘http://linuxgazette.net/105/price.html’][/URL]

    My Iomega Storcenter is NOT joined to the domain… It’s not necessary for me b/c I am using all of it for FOG.
    Thank you for your help! I was able to get it past the Unable to mount NFS share. (Think my task was still queued up and holding on to old settings.)



  • Just a thought, Since my Iomega NAS syncs to my windows Active Directory to get it’s users list, do I need to join my fog server to Active Directory?

    Currently it’s not joined to my domain. How do I go about joining it to the domain? Would I need to re-install FOG after this?



  • joshua,

    I edited the the default storage node definition in the webui. I set the IP to the IP of my NAS. I then set the image location to /mnt/pools/A/A0/[I]sharename[/I]. Because I am still hosting the TFTP files from the fog server I did not change the TFTP_HOST value. I did change STORAGE_HOST to the IP of the nas and edited the storage directories similar to above. Be sure that after you make these changes you remove any pxe files in the /tftpboot/pxelinux.cfg that are named by MAC addresses. Recreate both the image on the webui and remake the task.

    I also synced my passwords to be the same. Everything is set to “fog” and then the same password. Including the one on the storage definition page. I also created a fog user on my NAS that has the same password. [url]http://www.fogproject.org/wiki/index.php?title=FOGUserGuide#Separate_NFS_Server[/url]
    Be sure you have the .mntcheck files as well.

    The biggest thing for me is that I tried this before and it didn’t work, but it was using a pxe boot file that was generated before I made the changes. So it appeared as if I was getting nowhere. Once I deleted the old pxe file and recreated the task, I was able to image.

    Still unable to rename or move them via FTP…

    Cheers



  • Check the config file as well as the webUI(under [B]Other Information[/B]>> [B]Fog Settings[/B])… and I would check the database just to be sure (but the webUI should update the DB when you save)

    I would check to ensure all fog passwords have been updated to the password that you set manually.(TFTP and STORAGE_FTP_Password)

    Adam: Can you please share with me how you got it as far as you did? I have tried everything. I too have a Iomega storcenter and have had a heck of a time trying to overcome the Fatal Error: failed to mount NFS share.

    for TFTP_HOST do you use fog-server IP or StorCenter IP? or “STORAGE_HOST” ??
    Thanks



  • If I’m able to upload files, can I rule out mismatched passwords?

    Which passwords do I need to check?



  • Yeah, when I ftp to my NAS with filezilla both the root folder and the dev folder are 777…



  • ya i check already, plus in the default folder where the image are, I already put chmod -hR 777 /image, still it doesn’t work



  • Have you checked that the Fog account has permission on the folders ? If it doesnt then this will happen


Log in to reply
 

446
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.