New Issue with Fog 1.2.0 and iPXE boot



  • I have a Fog 1.2.0 install that was working.

    It is running on "precise1-Ubuntu SMP Thu Jan 30 17:39:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux"
    It was not used for several months and I made some infrastructure changes i.e moved from W2k3 to 2012 for our DC and DHCP. All the DHCP server settings look correct.

    However when I try to iPXE boot machines that were working I get

    tftp://<ip address>/%20undionly.kpxe … no such file of directory
    Note the %20 in the URL

    I can ftp undionly.kpxe from the fog server

    When I go to [URL=‘http://%3cip’]http://<ip[/URL] address>/fog/service/ipxe/boot.php
    I see the correct text for my boot menu. I have not made any changes to the menu that was working

    I think I am missing a fog configuration variable and that is why I am getting the %20

    It has to be something simple I am missing. Does anyone have any ideas on what I can check next?

    Thanks for your attention to this matter,
    GP



  • Thanks guys I knew it was something simple but I had been staring at it too long:)
    GP


  • Developer

    /etc/dhcp/dhcpd.conf
    [CODE]…
    filename “undionly.kpxe”;
    …[/CODE]
    and restart the service afer changing the config file:

    [CODE]service isc-dhcp-server restart[/CODE]



  • %20 is an encoded space. Check your DHCP-Settings for a space.


Log in to reply
 

462
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.