Cannot Boot from Hard Disk after PXE boot



  • Hi,

    I’ve scoured the forums for an answer to this, but I can’t seem to find a fix that I understand. I’m pretty new to Linux, but I’ve managed to get my FOG server up and running on Ubuntu (14.04). I registered my first host after a pxe boot, but my problem is booting from the hard disk (into Windows) when I don’t need to do anything in the pxe boot.

    Initially, it gave me a message saying that no operating system could be found. After playing around with the boot settings in the bios (Legacy only, Legacy first, UEFI and Legacy, etc), it now goes to a black screen with a blinking cursor.

    From what I’ve read, I’m guessing the answer lies in chainloading, but I haven’t been able to figure out what to change. What I’ve found ([url]http://fogproject.org/wiki/index.php/Boot_looping_and_Chainloading[/url]) seems to be outdated (undionly.kpxe is now used instead of pxelinux.0 and syslinux is up to 6.03) so the instructions don’t match up, and I’m not sure which files I should replace to force the system to go to the next item in the boot menu or to manually load the OS from the hard disk.

    Any help would be appreciated. Thanks in advance.



  • I thought that switching back and forth might be a problem. UEFI is still a bit of a mystery to me. I removed it completely from the boot sequence and options, but it doesn’t seem to matter. I’m not even sure what I need to do to eliminate UEFI from the process. When I get time, I’ll need to research that myself. At this point, I think it’ll be easier to just interrupt the boot sequence and select the pxe boot when I need to image a machine. Thanks for the help!


  • Senior Developer

    As Uncle Frank states, the BIOS being in UEFI mode may pose issues for you. If you’re needing to use UEFI, then I would recommend NOT making the NIC the first boot item in the list as I don’t have any EFI binaries that I can guarantee will hand back the informatoin back to the BIOS. That said, it sounds to me like the NIC is set to boot to LEGACY mode, which is also going to cause problems. None of the exit types from LEGACY can switch from legacy back to UEFI as it’s a whole different method of calling.



  • I’ve tried everything I know to do with the bios and boot options - still no luck.



  • There is only one physical disk, but it does have multiple partitions (created during the Windows installation). I guess it’s possible that it’s trying to boot from the cd drive or something. That seems like an odd message to receive, but I’ll try removing everything from the boot order except the pedevice and the HDD just to be sure.

    Also, I tried running the startup repair from a Windows 8 disk as another post suggested, and it said that it couldn’t repair it. When I turn off the pxe boot or bypass by manually selecting the startup device, I have no issue booting to Windows.

    I can’t get back into the school until tomorrow, but I’ll try some of these suggestions then.



  • is there 2 disks in the computer ? i already have the problem when my os is installed on the SATA-1 and i have a blank disk on SATA-0, he try to start on SATA-0 and say : Reboot and select proper Boot device or Insert Boot Media in selected Boot device and press a key


  • Developer

    Other people had similar issues. Solutions were kind of different. Please read through those posts and see if it’s of any help for you:
    [url]http://fogproject.org/forum/threads/after-deploye-grub-fog-1-2-0.11873/[/url]
    [url]http://fogproject.org/forum/threads/resizable-issue-with-bootloader.11882/[/url]

    Hint: forum/internet search… cmain

    AFAIK the grub method won’t work if you enable UEFI in BIOS… please, anyone correct me if this is not true!



  • I’ve upgraded the bios to version 13, and it made no difference.



  • Some more info:

    Fog version: 1.2
    OS version: Ubuntu 14.04 LTS

    The machines I’m trying to boot from were custom built by a company here. The motherboard is a Gigabyte B75M-D3V, bios version 11.



  • The version is 1.2. When I disable PXE boot, the computer boots into Windows just fine so there is something on the HDD. I mistakenly gave you the wrong error message. Here’s what I get when I try the three different methods.

    [U]Sanboot style[/U]
    “Reboot and select proper Boot device or Insert Boot Media in selected Boot device and press a key”

    [U]Exit style[/U]
    “Reboot and select proper Boot device or Insert Boot Media in selected Boot device and press a key”

    [U]Grub style[/U]
    Launching Grub…
    begin pxe scan… Starting cmain() …

    None of them actually boots back to Windows. It’s as if it’s incapable of going back to the HDD after the PXE boot menu. As I mentioned before, I’ve played around with the bios settings and haven’t been able to fix it. The closest answer I found was with the chainloading, but I couldn’t figure out how to implement it.

    Btw, I’m located in Russia at a school. We’re on spring break, and the building is only open today (Wed), Fri, and Mon so I may be slow to respond to your messages. I apologize for that and appreciate your help.


  • Senior Developer

    What version of FOG are you running?

    If it’s 1.2.0 you can change the boot exit type which is likely causing the issues you’re describing.

    Set the boot exit type to exit or grub from sanboot and you should see things working, kind of. The fact that you got the message saying that no OS could be found tells me there’s nothing on the HDD though so you may need to put an OS on it first.


Log in to reply
 

418
Online

39002
Users

10717
Topics

101762
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.