[SOLVED] WOL not working since 1.2.0



  • Hi everybody,
    I work in a school in France and we are using fog for a long time.
    We used the WOL function of FOG 0.32 with success.
    Since we install a new server with 1.0 release of Fog last year the WOL function doesn’t work.
    I check many times the network config, it seems ok.
    I tried this link : [url]http://192.168.8.3/fog/wol/wol.php?wakeonlan=AA:BB:CC:DD:EE:FF[/url] with no result.
    I install the application “wakeonlan” on my server and I test the comand :
    “wakeonlan AA:BB:CC:DD:EE:FF” in a console, my computer starts !!

    So I assume that my network config on the server is OK, and the client computer is also well configured as it start through the network.

    Can you give me a way where to find a solution ?



  • The wol function still doesn’t works with the SVN 3178 with proxy enable.
    My server works well now, whithout the proxy filed.
    In which cases I’ll need to filed the proxy filed ?

    Last question, I don’t understand your sentence :"but don’t have a viable way to test it myself."
    I my case I just have to put an IP adress in the field “[SIZE=13px][FONT=Ubuntu][COLOR=#555555]FOG_PROXY_IP”[COLOR=#000000] and the WOL function don’t work anymore on all computers on the same subnet of my server. I asume that you can try it on evry installation ? Or it’s just in my case ??[/COLOR][/COLOR][/FONT][/SIZE]



  • Hi, thank you for your answer.
    I’m runing the SVN 3126 and it still doesn’t works if I fill proxy and port … If I let these 2 fields blank the wol is working again.
    If I let the port number whithout ip adress it works.
    I also tried with another IP (not the correct one) and it still doesn’t works.
    Just for information my IP config is :

    The loopback network interface

    auto lo
    iface lo inet loopback

    The primary network interface

    auto eth0
    iface eth0 inet static
    address 192.168.8.2
    netmask 255.255.255.0
    network 192.168.8.0
    broadcast 192.168.8.255
    gateway 192.168.8.10
    dns-nameservers 192.168.8.9
    And the proxy is definied for apt in /etc/apt/apt.conf
    Acquire::http::Proxy “[url]http://192.168.8.10:8080[/url]”;
    I will make some tests with the SVN 3178 if you want.


  • Senior Developer

    Yog,

    If possible, can you maybe try with the proxy and proxy ports filled with the values you need on a dev version (SVN)? I ask because I’ve been working pretty hard to get the development version as bug free as I can. One of the things I know is that many of the “checks and balances” that happen during the WOL or any IP getting function of 1.2.0 sometimes tried going through proxy when this was not it’s intent. I’m hoping this is not the case any more, but don’t have a viable way to test it myself.



  • I don’t know where to find the option to edit the title of the post to add “Solved” at the end ?
    Maybe moderators only can do this ?
    I thank you in advance for your answer.



  • Hello, I just discover where was the problem.
    Deleting the database and recreating an empty one the WOL was working !! So I compare in the table “GlobalSettings” what are differences between my own config and the default one created by FOG, and I saw that I have in mine “proxy” and “proxy port” fields filled.
    I deleted these 2 fields and now my WOL function is working again !!

    I’m not sure is normal. Maybe development team can answer about this problem ?


  • Developer

    Do you see any error messages in your apache server logs??


  • Moderator

    Hi,

    Could you PM me (I’m french)

    Regards,
    Ch3i.


Log in to reply
 

445
Online

39174
Users

10821
Topics

102951
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.