Fog Client Host Renaming Windows 7 Enterprise 64x



  • When I was creating my image, the Fog Client would update host name every time it was installed (audit mode).

    I successfully was able to upload and deploy this image.

    Now even after rebooting, re installing, changing the service login credentials, and checking logs for the client. It will not rename the host machine.

    I scanned the forums and web for solutions but i cannot seem to figure this out, any hints or ideas?

    FOG 1.2.0
    Ubuntu 12.04.5 host

    Windows 7 Enterprise 64x image.



  • Hey, it was that i had Active directory settings in there, changed them in the main config for FOG,
    But the password located on the host machine pass was not encrypted… once i changed that it worked fine.

    Love your software man. Great Work.


  • Senior Developer

    Is ADPass an encrypted password or plaintext?



  • yeah I was changing the computer name, i read on a post if the name was shorter than the desired host name it would change it.



  • [CODE]#!ok=HP6715bOLD #AD=1 #ADDom=XXXXXXXX.Com #ADOU=OU=Win7Computers,DC=XXXXXX,DC=com #ADUser=XXXXXXXX.Com\XXXXXXX #ADPass=XXXXXXXXX[/CODE]


  • Senior Developer

    Your error logs seem to indicate this problem for hostname:

    [code] 3/10/2015 5:33 PM FOG::HostnameChanger AD mode requested, confirming settings.
    3/10/2015 5:33 PM FOG::HostnameChanger Could not find any recognizable digits.
    3/10/2015 5:33 PM FOG::HostnameChanger at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
    at System.Convert.ToByte(String value, Int32 fromBase)
    at FOG.FOGCrypt.hexToByte(String hex)
    at FOG.FOGCrypt.decryptHex(String hex)
    at FOG.HostNameChanger.changeHostName()
    3/10/2015 5:33 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    3/10/2015 5:33 PM FOG::GUIWatcher The system cannot find message text for message number 0x%1 in the message file for %2
    3/10/2015 5:33 PM FOG::GUIWatcher at System.Windows.Forms.Form.UpdateLayered()
    at System.Windows.Forms.Form.set_Opacity(Double value)
    at FOG.AbstractFOGService.attemptPushToGUI()
    at FOG.GUIWatcher.startWatching()[/code]

    What is the output of the browser if you goto the link:

    [url]http://192.168.77.41/fog/service/hostname.php?mac=00:1A:4B:61:43:E1[/url]

    Based on the info I’m seeing in this log, the current systems computer name is: RENAME



  • Is there a setting i can change that will call the function again, Registry Edit, File Config?

    And no the imaged machine had win-####### as host name.
    The host as stored on the server was HP####-OFW


  • Senior Developer

    The “incorrect” means are the hosts already named properly? We have a function that happens right after the imaging completes but before the system reboots that renames the systems for you.



  • Going to retrieve the log.

    UPDATED - Posted Log as Attachment

    [url="/_imported_xf_attachments/1/1777_fog.log.txt?:"]fog.log.txt[/url]



  • What do you mean are the name incorrect?
    It worked before in audit mode on the source machine the image was created on,
    But it will not work on the machine after the image is downloaded to a new host.

    It did other things like package deploy, and it is talking with the server according to the logs,
    The log how ever never mentions anything about the host renaming service.


  • Testers

    what does the fog log show


  • Senior Developer

    Are the names incorrect?


Log in to reply
 

490
Online

39003
Users

10718
Topics

101766
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.