IPXE Menu Customization in version 1.2.0-3083



  • Hi everybody,

    I know that the question is always the same (because i’ve serched a lot in the forum and found different thread about) but I can’t use the web menu to customize the iPxe Menu.

    I’ve add a new entry in the iPXE menu that i see when i boot from the network.
    I’ve also add the iso i need in the folder /var/www/fog/iso and i also can reach by web to this location, so where i’ve to add the string [B]initrd [url]http://${fog-ip}/${fog-webroot}/iso/deft-8.1.ISO[/url] [/B]to launch th boot of this iso?
    I’ve to add anything else?

    Thank you so much for u support.



  • [quote=“Uncle Frank, post: 43424, member: 28116”]Try adding it to the ‘Parameters’ field in your fog.Deft entry…[/quote]

    please can you help me with my project FOG
    and thanks



  • No, the client have 4 gb of RAM.
    It may depends on other setting that I may have not set correctly?


  • Senior Developer

    If the system you’re trying to load the ISO on doesn’t have 3.1 gb of ram it may produce what you’re seeing.



  • Ok, thanks a lot for the reply.
    I’ve had what u told me in the field parameters and now i’ve an iso that boot up fine but DEFT and also an iso of installation of windows 7 just does nothing and then boot windows.
    It may depends by the dimension of the iso? because DEFT is an iso of 3.1 GB.
    Or I need to do something else?


  • Senior Developer

    In the parameters, as you’re trying to boot the ISO, you need to add the elements to allow it to load the iso.

    [code]initrd http://${fog-ip}/${fog-webroot}/iso/deft-8.1.ISO
    chain memdisk iso raw[/code]



  • Thanks for the reply.
    I’ ve tried to put the string
    [B]initrd [URL=‘http://%24%7Bfog-ip%7D/$%7Bfog-webroot%7D/iso/deft-8.1.ISO’]http://${fog-ip}/${fog-webroot}/iso/deft-8.1.ISO[/URL] [/B]
    to parameters in the firt image of my previus post but when i boot form network and choose deft comes a blank screen and then boot windows.


  • Developer

    Try adding it to the ‘Parameters’ field in your fog.Deft entry…



  • [ATTACH=full]1758[/ATTACH][ATTACH=full]1759[/ATTACH]

    For a better explain I ve uploaded 2 images of iPXE Menu Configuration and FOG PXE Boot Menu Configuration in my FOG Configuration.

    Please tell me which configuration i’ve to modify

    thank u

    [url="/_imported_xf_attachments/1/1758_img1.png?:"]img1.png[/url][url="/_imported_xf_attachments/1/1759_img2.png?:"]img2.png[/url]



  • Sorry for the misundestanding.
    No i m not using the advanced menu. I ve just added a new voice menu with add ipxe menu entry (the voice on the left panel of fog configuration menu of the web pace of fog).


  • Senior Developer

    I guess I don’t understand.

    You’re using the FOG Configuration->iPXE Boot Menu->Advanced Menu?



  • No, I don’t even know what is it.
    Can you explain to me?


  • Senior Developer

    Do you have the chain memdisk iso raw flag?


 

431
Online

5.4k
Users

12.6k
Topics

118.9k
Posts