Strange behavior for images location



  • Hi,
    i’ve got a fog 0.32 with 2 hard drives. [B]The second[/B] is used for my images.
    In the fog interface,
    i created 2 storage grooups (disque1 and disque2)
    The image path in the image management is like /media/disque2/name of the image

    I created 2 storages nodes partage1 (link with disque1, image path =/media/disque1) & partage2 (link with disque2, image path=/media/disque2)

    I created on group with 2 computers. I associate an image located on the second disk (i tried several diffents images).
    If i download in unicast, no problem.
    If i try a multicast download, the clients boots, then waits in the process of downloading the image.
    In the fog viewer, i have : test multicast failed to execute, image file:/media/[B]disque1[/B]/name of the image not found!

    I read the fog wiki, this forum, but i didn’t see any solution. Any idea ?
    Thanks in advance



  • http://www.fogproject.org/wiki/index.php/Multicasting#Testing_1_Client

    udp-send : ok
    udp-receiver : no response arrive to the server.
    I will search and let you know what i found.


  • Senior Developer

    You can upgrade again and that issue should go away.



  • First, i apologize because my fog server wasn’t in 0.32 but in 1877 (version 1.1.0 ?)
    I upgraded after the uncle franck message (via http://www.fogproject.org/wiki/index.php/Upgrade_to_trunk
    with the svn method).
    No error during the upgrade.
    I did what explained Tom elliott in the third message (except i did it only for the second disk, i deleted all informations for the first disk).

    Problem, in the interface, i coud not have access to the Report Management (blanck screeen with only write version:3390)
    In apache2/error.log i saw
    http://127.0.0.1/fog/management/index.php?node=home
    Finally, i deleted all storage nodes in Storage Management -> access to Report Management OK
    But impossible to create a new Image (Blanck screen with write : add new image definition)
    If i add a storage node after that -> No access to report management
    But it’s possible to create a new image
    Is there a way to fix it ?


  • Senior Developer

    Based on the “test” messag eyou have there, does the file actually exist in /media/disque1/nameOfImageHere?

    The other thing, this is a customized setup I’m guessing, as you’re attempting to use /media as the mountpoint, and disque1 or disque2 based on the file?

    I believe the “bug” as Uncle Frank describes with 0.32 was that it always expected the nfs to be at /images. Due to this, you would need to modify the exports file as this did not occur naturally on the system when making such a change.

    Edit the exports file and create the needed entries to your relative mount points:

    Most likely entries like:

    /media/disque1/images                        *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /media/disque1/images/dev                    *(rw,sync,no_wdelay,no_root_squash,insecure
    /media/disque2/images                        *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /media/disque2/images/dev                    *(rw,sync,no_wdelay,no_root_squash,insecure
    

    Once those entries are made, you’ll need to refresh the nfs most likely with

    sudo exportfs -a
    

    As these are custom entries, I’d also make sure to first run:

    sudo touch /media/disque1/images/.mntcheck /media/disque1/images/dev/.mntcheck
    sudo touch /media/disque2/images/.mntcheck /media/disque2/images/dev/.mntcheck
    sudo chmod -R 777 /media/disque1/images
    sudo chmod -R 777 /media/disque2/images
    

  • Developer

    Is there a reason why you still use FOG 0.32? I am still new to this project and don’t know much about the old versions but I suppose this could be a bug in 0.32… and it won’t be fixed as we are heavily working on newer versions.

    Maybe you want to setup a new test server with FOG 1.2.0 or even developers version and see if the problem is still there. Please let us know and I am sure we’ll find a way to fix it!



  • a little up


Log in to reply
 

369
Online

38724
Users

10553
Topics

99875
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.