Issue with switch HP A5120-EI (presumed guilty)



  • Hi, i meet an issue with my new switch HP A5120-EI (presumed guilty)
    I can’t boot : it says [B]“Could not start download: Operation not supported ([url]http://ipxe.org/3c092003[/url])”. [/B]On our network, we have HP Procurve 2425 switches and it works very well - all is working fine (unicast, multicast) but not with these A5120. I tried another one (we have 2 - maybe the first one was buggy), same issue (with the default configuration). Something must be configured, but what ?
    (Ubuntu Server 12.04, FOG v. 1.2.0. Bonded NICs. undionly.kpxe in use (works fine). DHCP Windows 2012 Server.)
    Help needed! Thanks!
    [B][/B]



  • As i said before, Uncle Frank put me on the good way (DHCP issue). I tried before many options on the switch, and no one worked. My method for this was really empiric : many tests, many failed tests and - at least with DHCP relay - i succeed. It’s strange that a DHCP relay is necessary : all pc’s are on the same subnet. I don’t uderstand why, and i’m a little bit annoyed about this but it works for now. I made a upload/download with success. I hope that this DHCP relay won’t generate some issues on the network !


  • Developer

    Usually a switch operates on OSI layer 2 and there should be no need for DHCP relaying if all hosts are on the same subnet. But there are a lot of so called layer-3 switches around these days and I don’t really know about all that special stuff they do!
    Anyhow, great if you got it running now. Let us know about the details of you understand why because it could be helpful to someone else too at some point. :-)



  • Hi, thanks for the answer. You put me on the right way. I think it works now - i can boot and perform host registration. I set up on the switch a DHCP relay. It seems ok. It was - i hope - a “simple” issue with forwarding DHCP options as you said.
    Thanks again for the help.


  • Developer

    To me this sounds like the new switch is not properly forwarding all DHCP options send by the DHCP server. Some foo magic?? Maybe check for some kind of ‘IP helper settings’. Best way to debug this would be to use a HUB to connect between switch and client. Conect another computer with that HUB to capture the DHCP traffic and compare the DHCP offer packets coming from 2425/A5120-EI.

    If you don’t have a HUB handy you could also just connect the capture PC to the switch and request an address from the DHCP server. Again capture the DHCP traffic and compare the packets. Keep your eyes open for ‘next server’…


Log in to reply
 

346
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.