Is it possible to remove the FOG Quick image password?



  • Hi.
    We recently discovered the fog project and its really a great tool to handle imaging computers etc.
    But I’ve been searching up and down for a way to remove the password dialog that pops up when you click “quick image” after booting. Is there a way to remove this password dialog ?

    I know the password box is there for a reason ;) But for our purpose it would be best if it was removed since everyone who will be using this can be trusted.

    We are currently using developer branch 1.3.0

    Best Regards



  • login toto and password toto is a mobile account



  • I tried modify the fog.deployimage with this code:

    #login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param hostname ${hostname}
    goto host_${hostname} || goto autres
    :host_admin13
    param username toto
    param password toto
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    goto fin
    :autres
    login
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fin
    

    My test machine admin13 goes into the loop host_admin13, but login and password are not valid.
    It may be a coding problem for the password ?




  • Moderator

    @Tom-Elliott this is what he’s trying to do: https://forums.fogproject.org/topic/9290/boot-menu-configuration-document

    @lebrun78 For the one classroom that you want to not manage, give them their own server on their own vlan, or give the teacher ‘mobile’ access only. Or schedule the machines to just get imaged every single night or weekend or whenever the teacher requests the classroom be imaged. You can just schedule these things, we can walk you through it. Also it’s not hard to use groups to deploy whenever it’s requested either. If you’re using the FOG Client and DHCP and have WOL enabled, and you have systems set to boot to the network first, you can deploy to a classroom without being there and all will be fine.

    The amount of work involved with you continuing to do all of the imaging is not that much when your environment is setup to your advantage.

    0_1485785830906_Mobile Access.png



  • I would like, for a group of machine which the name is beginning by i207, not have to insert login/password to deploy image directly from pxe menu.
    But for all the other machines I would have to keep the login/password


  • Senior Developer

    @lebrun78 what are you trying to do? I can’t help without understanding what you are looking for.



  • indeed, I’m a drag


  • Senior Developer

    @lebrun78 I still don’t understand what you’re talking about.

    You posted to a thread that’s over a year old since it’s last communication asking about a procedure that I still don’t know what you’re looking for.

    The IPXE menu stuff is handled on the GUI now. the fog.quickimage script from the init’s perspective doesn’t exist which was already discussed in this thread as well. (https://forums.fogproject.org/topic/4433/is-it-possible-to-remove-the-fog-quick-image-password/3#)

    I don’t know what it is you’re asking or trying to accomplish.



  • this one :

    @Joseph-Hales said in http://fogproject.org/wiki/index.php/Modifying_the_Init_Image[/B]

    [B]%(#000000] [/B]

    [B]Remove Authentication from Quick Image[/B]

    This example will show how to automatically authenticate users when they select Quick Image. If you are happy to allow anybody to deploy an image to a hardrive this is for you.
    cd /tftpboot/fog/images
    gunzip init.gz
    mkdir initmountdir
    mount -o loop init initmountdir
    cd /tftpboot/fog/images/initmountdir/bin/
    Edit fog.quickimage
    Comment out the followig lines by putting a # in front
    #echo " Enter a valid FOG username and password.";
    #echo “”;
    #echo -n " Username)[
    Replace with:]
    username="a valid username"
    password=“a valid password”;
    Save the modification
    cd …/…
    umount initmountdir/
    rmdir initmountdir
    gzip init
    You are done and now users can image without the need for a username and a password.


  • Senior Developer

    @lebrun78 What procedure?

    iPXE menu items have never been “files” either.



  • @Tom-Elliott
    Is the procedure described above?

    the file fog.quickimage doesn’t exist on base 1.3.3.
    Should I add it ?


  • Senior Developer

    @lebrun78 Is what always available?



  • is it always available on 1.3.3 version ?



  • For the extra clarity, this worked for me. Edited /var/www/fog/lib/fog/BootMenu.class.php, the rows just below "…$option == ‘fog.quickimage’)

    //              print "login\n";
    				print "set username username\n";
    				print "set password password\n";
    

    /Thanks!



  • Thanks again Tom.
    Im sorry for the late reply. Been out of the country.
    I just wanted to say that the last solution you gave fixed it for us.
    Thank you so much for your help :)


  • Senior Developer

    I’ve found a solution:

    For the fog.quickimage menu item
    before the params setting put:

    set username fogguiusernamehere
    set password fogguipasswordhere
    

    Reset the param username and param password back to:

    param username ${username}
    param password ${password}
    

    This should work at least in my testing it has.



  • @Tom Elliott, post: 42476, member: 7271 said:

    Do you have anything in your apache error logs?

    Thank again Tom.
    According to the apache logs i keep getting this >

    [Fri Feb 20 16:55:48.371529 2015] [:error] [pid 2376] [client 172.16.200.14:33459] PHP Warning: array_unique() expects parameter 1 to be array, null given in /var/www/fog/lib/fog/HostManager.class.php on line 8

    Every time i click “quick image” from the main menu, and every time i click on a image on the next menu.But dont think thats related. This only happens when i havent registered the host. If i register it. Then i dont get any error message at all in the error log. But it still kicks me back to the main menu when i select an image


  • Senior Developer

    Do you have anything in your apache error logs?

    A good way to get the most out of the information:

    Start your client and get it “ready” to select an image to push but don’t choose an image yet.

    Open a terminal/ssh to your fog server. Run:

    sudo tail -100f /var/log/apache2/error.log
    

    Press enter on the the image you want to push to the client.

    Press CTRL+C on the ssh terminal. The last few lines of the error log should give you where the problem is.



  • Thank you very much Tom.
    We updated out build with the newest release on the dev branch and as you said, its now possible to edit this from the GUI.
    We did as you said and changed the param and removed “login”. And now it skips the login screen and lets us select the image right after clicking quick image :)

    But unfortunately it seems like the password autentication might still be required somewhere in the code.
    Because as soon as we click a image that we want to have installed. It jumps us back to the “fog menu” .
    With no error message other than a quick “returning to menu”.

    Best regards


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.