Error 2691



  • Hi just joined this group, some great stuff on here.
    I have been building images for some laptops at my place of work and have come into a problem. I have successfully built a number of images and have had no problem sysprepping and deploying them via FOG. Yesterday I had to redo an image that had a couple of issues so I used my presysprepped image and did the work on it and then sysprepped the machine and put the image on the FOG server. My laptop engineer went to image a laptop today and chose the same machine as I had taken the image off. This shouldn’t make a difference as when he started it he chose Full Host Registration and it asked for the laptops name (he renamed to what he wanted) and (allegedly) joined to the domain. When he went to log in to the machine using his domain log in it told him that “The security database on the server does not have a computer account for this workstation trust relationship”. I looked in AD and there is no entry for the laptop either under it’s renamed name or its previous name. I got the fog log off the machine which I have attached (note this is the log for today only though the log did have yesterday’s activity on the same machine which I can include if it is important for the problem) and within it I think this is the relevant part:

    04/02/2015 09:36 FOG::HostnameChanger AD mode requested, confirming settings.
    04/02/2015 09:36 FOG::HostnameChanger Hostname is up to date
    04/02/2015 09:36 FOG::HostnameChanger Attempting to join domain if not already a
    member…
    04/02/2015 09:36 FOG::HostnameChanger Domain Error! (‘SetupAlreadyJoined’ Code: 2691)

    If anyone can shed any light it would be useful as I have come to FOG from SCCM which I found to bloaty for our network and FOG is much more user friendly and I want to learn more.

    Thanks in adavance

    Andy

    [url="/_imported_xf_attachments/1/1648_FOGLOG1972.txt?:"]FOGLOG1972.txt[/url]


  • Testers

    Just throwing this out there check the AD user make sure its not locked and try to login manually and see if you can join the domain with that user manually.



  • I have the full domain name and user name and the password is encrypted.


  • Testers

    Do you have the full domain name entered for example mine is wisd.us and then for user it uses domain\user_name also remember to encrypt the password using the fog crypt password utility before entering it in. Note for username the domain can be shortened for example mine is wisd\user_name.



  • OK so I have taen another image re sysprepped it (making sure the image was not on the domain when I did so). I checked th box about joining AD and made sure the username and password were valid for accessing AD. But when I install the image it still won’t connect to the domain automatically. I enclose another copy of the log and I presume the problem is the error “Domain Error (‘Unknown Error’ Code: 2202)” but I have no idea what an unknown error is and I suspect nor does whoever wrote the code.

    [url="/_imported_xf_attachments/1/1652_fog05012015.txt?:"]fog05012015.txt[/url]


  • Senior Developer

    Based on the log I’m reading it looks like the checkbox for the host is not checked on for the host you want to join ad.



  • Hmmmm I reimaged etc but the issue is still there that it won’t join to the domain. I also have another machine with a different build that is doing the same and I know this build worked on other machines. I’m wondering if my hostnamechange.dll has changed somehow but not sure how to modify it or even check it if has (I’m not sure what to look for - though I have looked at it in notepad). I again enclose the .txt file to see if anyone can spot anything on that.

    [url="/_imported_xf_attachments/1/1651_fog050215.txt?:"]fog050215.txt[/url]



  • I looked at the image I originally installed and lo and behold it was connected to a domain. I have removed that added what was needed and sysprepped the image again and am now taking the image off and putting on FOG. I will post when I have installed it again onto another laptop and see if it connects to the domain and the image is correct.

    Thanks for the heads up


  • Senior Developer

    This means the resysprepped age was joined to the domain and most likely the Sysprep process did not have the generalize option selected. After that the machine name was removed from active directory. Fog believes it’s already joined and won’t try to do anything to it. That part is expected. To fix is recommend renaming the machine and restart the machine. It should rename them rejoin to domain. Then you can name it what it originally was and all should be fine. If the name was different from what the original images machine name was I think it would’ve worked as well.


Log in to reply
 

359
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.