TFTP: Client does not accept options



  • I’m having trouble PXE booting any PC
    Fog 1.2.0
    centos 6.4
    SELINUX Disabled
    IPtables off
    DHCP server 066 = fog2
    DHCP server 067 = undionly.kpxe

    I can tftp from a windows pc and the local box using the following commands:
    Windows:
    tftp fog2 get undionly.kpxe
    Transfer successful: 103273 bytes in 1 second(s), 103273 bytes/s

    FOG:

    [root@fog2 service]# tftp -v fog2 -c get undionly.kpxe
    Connected to fog2.unionky.edu (172.16.30.83), port 69
    getting from fog2.unionky.edu:undionly.kpxe to undionly.kpxe [netascii]
    Received 103273 bytes in 0.0 seconds [93980984 bit/s]

    Permissions on /tftpboot are fog:root 777
    Additionally permissions on /var/www/html/fog/service/ipxe are also apache:apache (tried fog:apache) 777

    I receive an error in /var/log/messages that says:

    Feb 3 09:26:41 fog2 xinetd[3808]: START: tftp pid=3821 from=x.x.x.x
    Feb 3 09:26:41 fog2 in.tftpd[3822]: tftp: client does not accept options
    On the client end i get Permission denied. I’m not sure what else to do at this point. additionally I had a fog server running .29 that i’ve upgraded in stages all the way to 1.2. It worked great until i upgraded from 1.1.2 to 1.2.


  • Senior Developer

    @VijayBomble This thread is extremely old and I have no idea what your particular problem is. based on the message of “on this switch it works, but that one it doesn’t” leads me to think a configuration issue on the switch that’s not working. There’s not anything that I can do to figure out what the problem is.



  • Hi Tom

    We also facing this issue if my client workstation connected on Arista L3 switch but if workstation connected with different network switch like HP procure it work properly


  • Senior Developer

    You can still have the page be redirected to https (for gui) but getting https on ipxe means having the cert loaded every time.



  • Ok so that fixed it. is there a way i can have it use https instead of http? I was trying to find this in the config files but i didn’t see anything.


  • Senior Developer

    can you make it so it doesn’t?



  • i believe so…


  • Senior Developer

    Seeing as that particular error code appears to be relevant to https, does your site redirect you to an https equivalent?



  • So here is what i’m getting when it tries to load the boot.php it fails with permission denied
    [url]http://[/url][fog IP]/fog/service/ipxe/boot.php…Permission Denied ([url]http://ipxe.org/0216ea3c[/url])
    Could not boot: Permission Denied

    however i can browse directly to that file and it pulls up fine. permissions on that directory ipxe are 777 and fog:apache



  • I actually have it set to the IP.


  • Developer

    does it work if you set option 66 to the IP instead?


  • Senior Developer

    The message “client does not accept options” is actually a normal message that I’ve seen.

    The permission denied worries me a little.


Log in to reply
 

487
Online

39005
Users

10720
Topics

101778
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.