Cisco IOS proper support for DHCP option 67



  • [FONT=Arial][COLOR=#333333]Hi everyone,[/COLOR][/FONT]
    [FONT=Arial][COLOR=#333333]This is defenitely NOT a FOG problem but I hoped someone here may have faced the same issue. Fine the IOS can’t accept raw option 67 specified directly as part of the scope configuration with the name of the boot file and instead TAC suggests to use “bootfile xxx.bin” to do the same thing but it is NOT the same!! Please![/COLOR][/FONT]
    [FONT=Arial][COLOR=#333333] You will see one Microsoft and one Cisco examples attached.[/COLOR][/FONT]
    [FONT=Arial][COLOR=#333333]Hello? Option 67 is missing on the Cisco side; yes the bootfile is present with a correct value but PXE booting clients need option 67 in order to extract the name of the file to be used during the TFTP bootstrap process.[/COLOR][/FONT]
    [FONT=Arial][COLOR=#333333]So what is the conclusion here? That no one can use Cisco’s IOS implementation of DHCP server in order to properly bootstrap PXE clients? Do tell me that I missed something :)
    [/COLOR][/FONT]
    [FONT=Arial][COLOR=#333333]Thank you everyone! [/COLOR][/FONT]
    [FONT=Arial][COLOR=#333333][ATTACH]1643[/ATTACH][ATTACH]1644[/ATTACH] [/COLOR][/FONT]

    [url="/_imported_xf_attachments/1/1643_cisco-dhcp.png?:"]cisco-dhcp.png[/url][url="/_imported_xf_attachments/1/1644_microsoft-dhcp.png?:"]microsoft-dhcp.png[/url]



  • YES the trick was [SIZE=5][B][FONT=Consolas]next-server <ip of PXE Server>[/FONT][/B][/SIZE]



  • Thanks Tom, this does appear credible and test is in order; will provide feedback:

    [CODE]ip dhcp pool <name>
    network <ip of network> <subnet mask>
    bootfile BStrap\X86pc\BStrap.0
    next-server <ip of PXE Server>
    default-router <network default gateway>
    netbios-name-server <one or more ip adresses>
    option 43 hex <hex values obtained from PXE Forced Mode Utility>
    option 66 ascii "name of PXE Server"
    option 60 ascii "PXEClient"
    dns-server <one or more ip addresses>
    option 150 <ip of PXE Server>
    domain-name <domain name>
    [/CODE]


  • Developer

    I use DNSMASQ with my cisco switches to pxe boot. [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url]

    I have not been successful in supplying the information directly to the switch.

    One thing that may help is an ip helper address too.

    You can also use the ip forward-protocol command and the no ip forward-protocol command to stop and traffic you don’t want to pass.

    If an IP helper address is specified and UDP forwarding is enabled, broadcast packets destined to the following port numbers are forwarded by default:
    Time Service Port 37
    TACACS Port 49
    Domain Name Services Port 53
    Trivial File Transfer Port 69
    DHCP (BootP) Port 67 and Port 68
    NetBIOS Name Server Port 137
    NetBIOS Datagram Server Port 138

    I should probably note that the preferred method is ip helper, as it should always work.


  • Senior Developer

    ip dhcp pool <name>
    network <ip of network> <subnet mask>
    bootfile BStrap\X86pc\BStrap.0
    next-server <ip of PXE Server>
    default-router <network default gateway>
    netbios-name-server <one or more ip adresses>
    option 43 hex <hex values obtained from PXE Forced Mode Utility>
    option 66 ascii "name of PXE Server"
    option 60 ascii "PXEClient"
    dns-server <one or more ip addresses>
    option 150 <ip of PXE Server>
    domain-name <domain name>

    From: [url]http://www.symantec.com/business/support/index?page=content&id=HOWTO8974[/url]


  • Senior Developer

    Option 67 is the filename. Option 66 is the server.

    I don’t know what cisco iOS uses to distinguish, but typically there’s either Option 66/67 or next-server/filename setting.


Log in to reply
 

406
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.