Storage node testing and disk information not displayed



  • Hello,

    Firstly, thanks to the devs. Fog is excellent.

    I have deployed a storage node and have a couple of questions.

    • I am using the location plugin, how can I test to be sure the image is being pulled from the correct storage node? Everything seems ok in testing I just can’t find the log to confirm. I don’t want to flood the WAN with image traffic.
    • The web GUI disk information does not work for my storage node. It just says failed to connect
    • ""

    Any ideas?
    Thanks



  • @Ben-Warfield

    Thank you Ben, just updating, simply comment de bind address on my.cnf solves the issue.


  • Developer

    No the webgui is not encrypted.



  • [LEFT]Does it encrypt the password in GUI “FOG_STORAGENODE_MYSQLPASS” ?
    [/LEFT]



  • Hello,
    I have the same problem, and nothing work.
    I have a ubuntu 14.04 server and fog 1.2.
    Thanks


  • Senior Developer

    No problem.



  • I was able to fix it.
    Turns out I had had changed the user and password in the config.class.php file when I was testing to see if that’s what the problem was. I changed it back to fogstorage and password and now it’s working.

    My issue was just that the mysql db needed updated.

    Thank You so much!


  • Senior Developer

    Now,

    From the storage node, can you perform the same command, just adding -h’IPOFFOGSERVER’



  • Yes, I was able to log in with those credentials, and yes the bind-address is commented out.
    I restarted the mysql service and I still get the failed to connect error.


  • Senior Developer

    The default is a randomly generated one performed at install time. It only happens the first install.

    The fact that it reports 0 rows affect tells me, it seems, that updating this field is working properly as well.

    A test you could do could be to sign in to mysql using the password you set and the same info:

    mysql -u fogstorage -p'<your-fogstorage-pass-here>' fog
    

    Does it allow you in with this? Also, is the /etc/my.cnf bind-address commented out?



  • Return said "Query OK, 0 rows affected (0.00 sec)"
    I restarted mysql and I’m still having the same issue.

    Is it possible that I could just change the password in the GUI and in the node back to the default (whatever that is)?
    The only reason I changed it was because I had no idea what it was and it was in hidden characters.


  • Senior Developer

    You need to login to the mysql instance. From a terminal on the FOG server run the command:

    mysql -u root fog
    

    Then run the above command.



  • Where do I enter that?


  • Senior Developer

    If you’re comfortable with the mysql syntax, you’re more likely going to have to change the fogstorage password in the db then.

    To do this the syntax should be:

    SET PASSWORD FOR 'fogstorage'@'%' = PASSWORD('new-password-here'); FLUSH PRIVILEGES;
    

    This should help out.



  • Tom,

    I changed that password in the GUI because I was unsure what the default was and I had to enter the credentials when I was installing FOG.
    So the credentials in my storage node currently match what is in that location.


  • Senior Developer

    Yes,

    the Storage node password for the (fogstorage) user is found in:

    FOG Configuration Page->FOG Settings->FOG Storage Nodes->FOG_STORAGENODE_MYSQLPASS



  • On the server username is root, and password is null. On the node the username is fog storage and the password is password.
    I’m guessing that’s where my problem is?



  • In the Config.class.php file, there’s a section not too far from the top of the file that starts with “private static function db_settings()”.
    Database_host should most likely be ‘localhost’ unless you have your database stored somewhere else
    Database_name should be fog
    Database_username and Database_password should be an account with access to the fog database. I’ve changed my username/password so I can’t tell you for sure what the default is



  • I did notice that between my FOG server and the storage node the TFTP_FTP_PASSWORD value was different. I changed that line so they matched and restarted mysql, but I still am receiving the same error.



  • Both my fog server and my storage node are using Ubuntu 14.4.

    can you please elaborate what you mean by “correct mysql connection info in the db_settings function.”

    Thank you!


Log in to reply
 

340
Online

38727
Users

10554
Topics

99921
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.