DHCP Conflicting sorted..... but now clients load ipxe....but missing file?



  • Hi Guys,

    today i discovered my FOGserver was clashing with our onsite DHCP server.

    I could fix the issue by turning the FOGserver off.

    so i decided to stop the DHCP service on the fog machine using;

    sudo /etc/init.d/dhcp3-server stop
    sudo sysv-rc-conf dhcp3-server off

    this didn’t fix the issue, as it couldn’t “stop” the service.

    I then decided to remove the DHCP service using;

    “sudo apt-get remove isc-dhcp-server”

    this worked! yay…

    …but now my clients can boot to ipxe, but i get the following error… can anybody help?

    thanks in advance.

    [ATTACH=full]1627[/ATTACH]

    [url="/_imported_xf_attachments/1/1627_IMG_20150123_143023093.jpg?:"]IMG_20150123_143023093.jpg[/url]


  • Senior Developer

    The simple answer, because it’s Ubuntu, the “harder” answer, because it’s using upstart/systemd.

    The answer to make it “automated” as you request, can be found on the forums. Specifically look for one of my posts today where I go almost fully in depth. I forget where.



  • Hi Tom,

    If i restart the fog server, i have to run

    [CODE]sudo service mysql restart[/CODE]

    everytime to get fog back online…Can you tell me how to automate this issue please? or educate me on why i have to do this after every restart?

    thanks once again



  • HI Tom,

    Restarting MYSQL fixed mt issue.

    Once again thank you very much for taking to time to look at this and help me (again).

    It’s great knowing that if i get stuck, i can also ask for help here from yourself and the community. Being a linux newbie, that means alot.

    cheers


  • Senior Developer



  • EDIT: SVN update seems to have fixed it!!


  • Senior Developer

    I fail to see how this is similar. Your issue is well known about and is fixed in svn as well as a number of threads have a workaround for 1.2.0



  • Hi Guys, I’m getting very similar.

    Fog version: 1.2.0
    Ubuntu: 14
    Hosted on a Hyper-V VM on 2008R2. Have always had 0.32 version and it worked great. Decided to build another one from scratch for the update … and now this is happening…

    I have checked the Apache logs and nothing really sticks out. Not 100% sure what I’m looking for, though. It was just a standard installation, but I put ‘Y’ when it asked … something. Something to do with client DNS I think.

    I’ve read some other comments on this, but some of the locations they’re saying aren’t even on my install. I’ve tried turning firewall off and restarting SQL, and the VM a bunch of times and DHCP looks fine to me.

    Have rebuilt a bunch of times and I am now out of ideas on what might be happening here.

    Please help.

    [url="/_imported_xf_attachments/1/1633_NEW FOG 4.jpg?:"]NEW FOG 4.jpg[/url]



  • Hi Tom thanks for your help on this… i’m not back on site now till Monday, So i’ll get right back on it then. Thax again.


  • Senior Developer

    I’d first start with just restarting the mysql service:

    [code]sudo service mysql restart[/code]



  • Hi, Visiting 10.15.20.13 gives me a “It works” “Apache2 Ubuntu Default Page” and doesn’t redirect me.

    Visiting 10.15.20.13/fog however, takes me to the “database Schema Installer/Updater” (Which i wasn’t expecting!)

    Clicking “Install/Upgrade Now” gives me “Database Schema Installer / Updater
    Update/Install Failed!”… Guess here lies the problem?.. it’s worth mentioning fog was “reinstalled” before i removed the dhcp…but everything was fine before that…

    Thanks for looking at this for me… should a run the fog installer again?

    [SIZE=6][B][FONT=Ubuntu][CENTER][SIZE=32px][COLOR=#666666] [/COLOR][/SIZE][/CENTER][/FONT][/B][/SIZE]


  • Senior Developer

    When you go to your webpage, do you do:

    [url]http://10.15.20.13/[/url]

    or do you do:

    [url]http://10.15.20.13/fog[/url]

    If you do the one without fog, does it auto redirect you to:

    [url]http://10.15.20.13/fog[/url] or stay as [url]http://10.15.20.13?[/url]



  • No not that i’m aware of, where’s best to check?

    thanks


  • Senior Developer

    Are you using a redirect/virtual host configuration to host fog?


Log in to reply
 

885
Online

39174
Users

10821
Topics

102951
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.