WOL problem since upgrade 1.2



  • Hi, i just migrate from 0.32 to 1.2 the migration goes well no error, but since then the wake on lan doesn’t work the log show no errors :
    [01-16-15 12:01:40 pm] * 1 active task(s) awaiting check-in sending WOL request(s).
    [01-16-15 12:02:00 pm] - Host: mycomputer WOL sent using MAC: xx:xx:xx:xx:xx:xx
    [01-16-15 12:02:00 pm] * No tasks found!
    [01-16-15 12:03:00 pm] * 1 active task(s) awaiting check-in sending WOL request(s)
    but nothing happens, any ideas that i can try ?

    thanks for any help
    Regards


  • Developer

    if the wol task is not working automatically, but works for the same host when done manually from the url, and all of the settings are correct, i don’t know what could possibly be wrong



  • Hi, tu resume :
    [URL=‘http://fogproject.org/fog/wol/wol.php?wakeonlan=<MACofClientToWakeWithColons>’][U][COLOR=#0066cc]http://<IP.OF.FOG.SRV>/fog/wol/wol.php?[/COLOR][/U][/URL] > working
    upload/download/wake up task > not working (i mean wake on lan no working)
    /var/log/apache2/error.log > no error
    the fog wol settings is : /fog/wol/wol.php
    the FOG_WOL_INTERFACE : eth0 (that’s ok too)
    and the F[FONT=Ubuntu][COLOR=#555555]OG_WOL_HOST is correct[/COLOR][/FONT]

    all seems ok but it doesn’t work, what else can i check ? if the url with /fog/wol is working that mean the problem is in the web server when it launch the command no ?
    thanks for any help.



  • Yes all is the same i have made an upgrade the networking hasn’t changed.


  • Developer

    is the new install of 1.2.0 on the same computer/subnet/IP as the 0.32 server was?
    could there be networking details that were not reconfigured for the new server, such as forwarding?



  • You are right these errors come when i try the url [URL=‘http://%3Cip.of.fog.srv%3E/fog/wol/wol.php?wakeonlan=%3CMACofClientToWakeWithColons%3E’]http://<IP.OF.FOG.SRV>/fog/wol/wol.php?wakeonlan=<MACofClientToWakeWithColons>[/URL] i made mistake and type [URL=‘http://%3Cip.of.fog.srv%3E/fog/wol/wol.php?wakeonlan=%3CMACofClientToWakeWithColons%3E’]http://<IP.OF.FOG.SRV>/fog[/URL]/wol.php
    the error come from here.

    So my wol seem to be well configured (no error in error_log) but still nothings happen when i try to upload/download/wake on lan etc

    what else can i try ?
    thank you


  • Senior Developer

    The base.inc.php isn’t really that, it’s searching for the base.inc.php in /usr/share/php (which does not exist on ubuntu) and can’t find the file there. So it spits out an error that really isn’t necessary or show stopping.

    The errors about the [code][Fri Jan 16 13:24:22.319934 2015] [:error] [pid 26227] [client 10.70.48.119:59685] script ‘/var/www/html/fog/wol.php’ not found or unable to stat
    [Fri Jan 16 13:24:32.703634 2015] [:error] [pid 26227] [client 10.70.48.119:59697] script ‘/var/www/html/fog/management/wol.php’ not found or unable to stat
    [Fri Jan 16 13:30:56.933885 2015] [:error] [pid 31855] [client 10.70.48.119:59816] script ‘/var/www/html/fog/wol.php’ not found or unable to stat[/code]

    Loos to me like you were trying different methods to get to the file, all of which do not exist.

    These aren’t being repeated all over the place though, which is what’s leading me to think it was you trying to go to the link, and it found those errors.



  • yes it is /fog/wol/wol.php
    those error as strange as the /var/www/fog/commons/base.inc.php exist
    and the path for my wol is /fog/wol/wol.php so i don’t understand why those two errors.

    also i have try many wake on lan and sometimes there is no error on the error_log (but that does not work either)

    i have try again 4-5 wake on lan no error on error_log but nothing happen :/
    is there a way to debug to see where the problem is ?
    thanks


  • Senior Developer

    In FOG Configuration->FOG Settings

    General Settings->FOG_WOL_PATH

    It should be:

    /fog/wol/wol.php



  • i have look at the error log and there seem to be some problems :
    [Wed Jan 14 07:34:06.469591 2015] [:error] [pid 1879] [client 10.70.48.83:1050] PHP Warning: require(…/commons/base.inc.php): failed to open stream: No such file or directory in /var/www/fog/service/servicemodule-active.php on line 2
    [Wed Jan 14 07:34:06.469622 2015] [:error] [pid 1879] [client 10.70.48.83:1050] PHP Fatal error: require(): Failed opening required ‘…/commons/base.inc.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/fog/service/servicemodule-active.php on line 2
    [Fri Jan 16 13:24:22.319934 2015] [:error] [pid 26227] [client 10.70.48.119:59685] script ‘/var/www/html/fog/wol.php’ not found or unable to stat
    [Fri Jan 16 13:24:32.703634 2015] [:error] [pid 26227] [client 10.70.48.119:59697] script ‘/var/www/html/fog/management/wol.php’ not found or unable to stat
    [Fri Jan 16 13:30:56.933885 2015] [:error] [pid 31855] [client 10.70.48.119:59816] script ‘/var/www/html/fog/wol.php’ not found or unable to stat

    i have seen a post with similar problem but i have not found the solution for me
    the fog wol settings is : /fog/wol/wol.php
    the FOG_WOL_INTERFACE : eth0 (that’s ok too)
    and the F[FONT=Ubuntu][COLOR=#555555]OG_WOL_HOST is correct[/COLOR][/FONT]



  • Hi, thanks for your reply, yes the wol is ok on the computer.
    if i try the url with [URL=‘http://%3Cip.of.fog.srv%3E/fog/wol/wol.php?wakeonlan=%3CMACofClientToWakeWithColons%3E’]http://<IP.OF.FOG.SRV>/fog/wol/wol.php?wakeonlan=<MACofClientToWakeWithColons>[/URL]
    the computer startup correctly.
    The fog and the computers are on the same subnet.
    any ideas ?
    thanks


  • Senior Developer

    Is the system you’re attempting to WOL have WOL enabled? I’m sure it does but always good to double check.

    The other thing to verify. When you were on 0.32, did you guys use a customization in your environment to get WOL working in the first place? If it’s not working under 1.2.0, I’m guess a base install of 0.32 would also show the same problems. Only difference in 0.32 and 1.2.0 is the rewrite is using direct sockets to pass the information, which I have tested multiple times and it does operate.

    One way to see if things are working would be to go to, from the browser:

    [url]http://<IP.OF.FOG.SRV>/fog/wol/wol.php?wakeonlan=<MACofClientToWakeWithColons>[/url]

    Does the system startup? Or does it not do anything? The other thing to verify is that the system is on the same subnet (layer 2) of your FOG Server or ensure your switches are setup to enable passing of this information. If you cannot do this, you could install SVN FOG and test some of the features. I’ve created a plugin called WOLBroadcast, which all you do is put in all your network Broadcast address (10.51.255.255, 10.77.255.255, 192.168.5.255) and when WOL is operating, it will send the packets to all of the listed broadcast addresses.


Log in to reply
 

444
Online

39174
Users

10821
Topics

102951
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.