FOG TFTP server address prompt -- Any ideas?



  • Fog 1.2 under Ubuntu 13.10 with a proxy dhcp server. After some tweaking, this install seems to be working perfectly with one exception. After the initial pxe boot, there is a prompt to enter the ip address of the tftp server (pic attached). Entering the address allows the boot process to continue.

    This did not happen with the kernels we previously tested in Fog 1.2 or with any kernel in Fog .32.

    I am using the [B]undionly.kpxe[/B] from [B][I][url]http://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp[/url][/I][/B], as suggested by Tom Elliott. This boots our 790s and 7010s.

    I’ve looked everywhere I can think of to plug in the server address, but to no avail. Below are some of the config files for the server.

    Not sure where else to check. TE suggested building a custom undionly.kpxe, but I’d like to see about an easier solution, if one exists, before opening that can of worms.

    All help/suggestions appreciated.

    [U][B]default.ipxe[/B][/U]
    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain [url]http://10.58.11.55/fog/service/ipxe/boot.php##params[/url]

    [U][B]ltsp.conf[/B][/U]

    if port=0 is not commented out, we lose internet connectivity on the fog server,

    but all server functions work

    port=0

    log-dhcp

    enable-tftp

    tftp-root=/tftpboot
    dhcp-boot=undionly.0,10.58.11.55

    dhcp-option=17,/images

    dhcp-option=vendor:PXEClient,6,2b

    dhcp-no-override
    pxe-prompt=“Press F8 for boot menu”, 3
    pxe-service=X86PC, “Boot from network”, undionly

    pxe-service=X86PC, “Boot from local hard disk”, 0

    pxe-service=x86PC, “Install windows from RIS server”, 1

    dhcp-range=10.58.11.55,proxy

    dhcp-range=192.168.0.20,192.168.0.250,8h

    dhcp-host=00:20:e0:3b:13:af,10.160.31.111,client111,infinite

    [U][B]tftpd-hpa[/B][/U]
    sleep 30

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“10.58.11.55:69"
    TFTP_OPTIONS=”-s"

    [url="/_imported_xf_attachments/1/1601_IMG_20150112_135614954_HDR.jpg?:"]IMG_20150112_135614954_HDR.jpg[/url]


  • Senior Developer

    No problem, it’s what I’m here for…I think. ;)



  • Many thanks, Tom. I’ll give it a try.


  • Senior Developer

    [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp/[/url]

    Any, and/or all, of those files (specifically the undionly.kpxe for your environment I think)



  • What is the link to that folder, Tom?


  • Senior Developer

    SVN 2891 should fix the tftp natively now.



  • That looks like it did the trick, Tom. Tested with and without a task and it booted as expected. This will make the rest of the week (and semester) much easier. Many thanks.


  • Senior Developer



  • Tom,

    I would certainly appreciate your assistance. There are several more labs to image this week and entering the tftp server ip address on each machine multiple times is not ideal. The server address is 10.58.11.55. I am using the undionly.kpxe that you suggested last week (link above). Attached is a pic of the error message if the server is incorrectly entered.

    This is puzzling to me, also, as this issue only cropped up once last week while I was testing various kernels and it wouldn’t boot anyway.

    [url="/_imported_xf_attachments/1/1602_IMG_20150112_170252892_HDR.jpg?:"]IMG_20150112_170252892_HDR.jpg[/url]


  • Senior Developer

    Glenn, if you need help in getting the tftp server setup so it’s automatically assigned, just let me know what your tftp server’s IP address is and I’ll do the building for you.

    I haven’t narrowed down what or why this is occurring but it only seems to occur on the dnsmasq (proxyDHCP) setup’s. The issue was found in that the next-server/option 67 item wasn’t being passed properly.

    If you want to try a simple setup, I’m guessing dnsmasq is residing on the FOG Server AND the FOG Server is also the tftp server? You could try the dhcp-boot=undionly.kpxe (no trailing characters).

    The confusing part to me is that the next-server isn’t passing which seems odd as something is telling it to look there to begin with (potentially the dnsmasq service itself).


Log in to reply
 

365
Online

38984
Users

10712
Topics

101689
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.