Svn upgrade failed.



  • i tried to upgrade to the latest svn from version 2580 to the latest svn version 2868 all seem to be going fine but when i tried to to the database schemea update when i click on the link , all i got was the login box for fog no update database option.

    I have tried editing my .fogsettings file and adding in localhost as my servername but no joy

    The server is not live yet but i was practically built and i hate to have to start from scratch,.

    I dont have any error logs in /var/log/mysql

    Any idea where to start debugging.
    My .fogsettings is below.

    [QUOTE]## Created by the FOG Installer

    Version: 1.3.0

    Install time: Mon 05 Jan 2015 14:38:27 GMT

    ipaddress=“192.168.2.1”;
    interface=“eth1”;
    routeraddress="#option routers x.x.x.x;";
    plainrouter="";
    dnsaddress="#option domain-name-servers x.x.x.x; “;
    dnsbootimage=”";
    password=“4452cc”;
    osid=“2”;
    osname=“Debian”;
    dodhcp=“Y”;
    bldhcp=“1”;
    installtype=“N”;
    snmysqluser="“
    snmysqlpass=“cbefog”;
    snmysqlhost=“localhost”;
    installlang=“0”;
    donate=“0”;
    storageLocation=”/images";
    fogupdateloaded=“1”[/QUOTE]


  • Developer

    Finally!!

    Thanks to TOM and everyone else on here who helped me out.

    I wont be touching it again for a while.

    Why cant be I be in bin directory while running svn?[/quote]
    because it’s only updating the files in the bin directory if you’re in the bin directory when you run the update, which is 2 files



  • :D

    Finally!!

    Thanks to TOM and everyone else on here who helped me out.

    I wont be touching it again for a while.

    Why cant be I be in bin directory while running svn?


  • Senior Developer

    You cannot be in bin to perform the update.

    You have to be one level down:

    so [code]root@MaynoothFogServer:~/svn/trunk/bin# cd ~/svn/trunk/bin[/code] should be:
    [code]root@MaynoothFogServer:~/svn/trunk/bin# cd ~/svn/trunk; svn up; cd bin[/code]



  • mysql prompt line

    mysql>



  • [quote=“Tom Elliott, post: 41001, member: 7271”]The code to sign into mysql should be:

    [code]mysql -u root -p’cpefog’ fog[/code]

    It should bring you to a prompt that looks like:
    [code]mysql>[/code]

    If you get there, it means you’re logging into the Database fine.

    For #5 (Are there any errors on your screen when trying to login to the database?), it still sounds, to me, like you’re not running the updater and are still at 2580. The SVN folder doesn’t automatically update to the latest or later revisions, you have to perform work.

    For example, if your original SVN download folder was located in /opt/fog_trunk by running command:

    [code]svn co https://svn.code.sf.net/p/freeghost/code/trunk /opt/fog_trunk[/code]

    To update you would perform:
    [code]cd /opt/fog_trunk
    svn update
    cd bin
    sudo ./installfog.sh[/code]

    This would then perform the upgrade. As you state you’re able to to login and no database schema is being presented to you, it sounds, to me, like you’re not actually updated. SVN does not update automatically for you.[/quote]

    sorry that command works fine i get the mssql prompt fine.

    i been using this commands which i found on the wiki

    cd ~
    mkdir svn
    cd svn
    svn checkout [url]https://svn.code.sf.net/p/freeghost/code/trunk[/url]

    [SIZE=4][B]Install It![/B][/SIZE]

    cd ~/svn/trunk/bin
    ./installfog.sh

    running your commands i get

    root@MaynoothFogServer:~/svn/trunk/bin# cd ~/svn/trunk/bin
    root@MaynoothFogServer:~/svn/trunk/bin# svn up
    At revision 2914.
    root@MaynoothFogServer:~/svn/trunk/bin#


  • Senior Developer

    The code to sign into mysql should be:

    [code]mysql -u root -p’cpefog’ fog[/code]

    It should bring you to a prompt that looks like:
    [code]mysql>[/code]

    If you get there, it means you’re logging into the Database fine.

    For #5 (Are there any errors on your screen when trying to login to the database?), it still sounds, to me, like you’re not running the updater and are still at 2580. The SVN folder doesn’t automatically update to the latest or later revisions, you have to perform work.

    For example, if your original SVN download folder was located in /opt/fog_trunk by running command:

    [code]svn co https://svn.code.sf.net/p/freeghost/code/trunk /opt/fog_trunk[/code]

    To update you would perform:
    [code]cd /opt/fog_trunk
    svn update
    cd bin
    sudo ./installfog.sh[/code]

    This would then perform the upgrade. As you state you’re able to to login and no database schema is being presented to you, it sounds, to me, like you’re not actually updated. SVN does not update automatically for you.



  • [quote=“Wolfbane8653, post: 40602, member: 3362”]
    [LIST=1]
    []When fog installed did you use a password for the database?
    [
    ]Can you login to the database using username root? --> mysql -u root fog
    []If yes to question 1, can you login to the database using --> mysql -u root -p <password you entered> fog
    [
    ]Do you have any errors in your mysql log?
    []Are there any errors on your screen when trying to login to the database?
    [
    ]What does show up when you go to your fog server URL? (picture required)
    [*]Can you give use your apache error log file? (file upload required)
    [/LIST]
    Pictures and/or video work wonders![/quote]

    1. cbefog
    2. NO, ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)
    3. log in dropbox link
    4. log in dropxbox link
    5. No everything works fine
    6. see dropbox link
    7. see dropbox link
      [url]https://www.dropbox.com/sh/28lsxa5p6o9jq0q/AAC81thnbPn2MrF2xhxVFUsea?dl=0[/url]


  • been snowed under with other work, hope to get back to looking at this today.

    ill relook at the questions list again.


  • Senior Developer

    Now that I have a better understanding of what possibly is happening.

    How are you updating this?

    Are you just going to the originally installed svn folder and re-running the installfog.sh file?

    I ask this because the folder you downloaded when you first installed to SVN does not automatically update.

    The process should be (lets assume your svn folder is currently located in the location /opt/fogsvn)
    [code]sudo su -
    cd /opt/fogsvn
    svn up
    cd bin
    ./installfog.sh[/code]


  • Developer

    You got your numbers mixed up.

    1. is blank and is very important…run mysql -u root -p cbefog fog
    2. Should be the terminal output
    3. should be a browser screen shot
    4. should be your dropbox link

  • Senior Developer

    The fact that you’re presented with the login page tells me your mysql settings in /var/www/fog/lib/fog/Config.class.php are 100% correct.

    My feeling is that your password to login to the FOG GUI is not correct.

    Try:
    username: fog
    password: password



  • [quote=“Wolfbane8653, post: 40602, member: 3362”]
    [LIST=1]
    []When fog installed did you use a password for the database?
    [
    ]Can you login to the database using username root? --> mysql -u root fog
    []If yes to question 1, can you login to the database using --> mysql -u root -p <password you entered> fog
    [
    ]Do you have any errors in your mysql log?
    []Are there any errors on your screen when trying to login to the database?
    [
    ]What does show up when you go to your fog server URL? (picture required)
    [*]Can you give use your apache error log file? (file upload required)
    [/LIST]
    Pictures and/or video work wonders![/quote]

    1. password is cbefog
    2. No error. root@MaynoothFogServer:/home/cbe# mysql -u root fog
      ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

    [CODE]150109 15:59:14 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    2015-01-09 15:59:14 16398 [Warning] Buffered warning: Changed limits: max_open_files: 1024 (requested 5000)

    2015-01-09 15:59:14 16398 [Warning] Buffered warning: Changed limits: table_cache: 431 (requested 2000)

    2015-01-09 15:59:14 16398 [Note] Plugin ‘FEDERATED’ is disabled.
    2015-01-09 15:59:14 16398 [Note] InnoDB: Using atomics to ref count buffer pool pages
    2015-01-09 15:59:14 16398 [Note] InnoDB: The InnoDB memory heap is disabled
    2015-01-09 15:59:14 16398 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
    2015-01-09 15:59:14 16398 [Note] InnoDB: Memory barrier is not used
    2015-01-09 15:59:14 16398 [Note] InnoDB: Compressed tables use zlib 1.2.7
    2015-01-09 15:59:14 16398 [Note] InnoDB: Using Linux native AIO
    2015-01-09 15:59:14 16398 [Note] InnoDB: Not using CPU crc32 instructions
    2015-01-09 15:59:14 16398 [Note] InnoDB: Initializing buffer pool, size = 128.0M
    2015-01-09 15:59:14 16398 [Note] InnoDB: Completed initialization of buffer pool
    2015-01-09 15:59:14 16398 [Note] InnoDB: Highest supported file format is Barracuda.
    2015-01-09 15:59:14 16398 [Note] InnoDB: 128 rollback segment(s) are active.
    2015-01-09 15:59:14 16398 [Note] InnoDB: Waiting for purge to start
    2015-01-09 15:59:14 16398 [Note] InnoDB: 5.6.22 started; log sequence number 1725047
    2015-01-09 15:59:14 16398 [Note] Server hostname (bind-address): ‘127.0.0.1’; port: 3306
    2015-01-09 15:59:14 16398 [Note] - ‘127.0.0.1’ resolves to ‘127.0.0.1’;
    2015-01-09 15:59:14 16398 [Note] Server socket created on IP: ‘127.0.0.1’.
    2015-01-09 15:59:14 16398 [ERROR] Column count of mysql.events_waits_current is wrong. Expected 19, found 16. Created with MySQL 50540, now running 50622. Please use mysql_upgrade to fix this error.
    2015-01-09 15:59:14 16398 [ERROR] Column count of mysql.events_waits_history is wrong. Expected 19, found 16. Created with MySQL 50540, now running 50622. Please use mysql_upgrade to fix this error.
    2015-01-09 15:59:14 16398 [ERROR] Column count of mysql.events_waits_history_long is wrong. Expected 19, found 16. Created with MySQL 50540, now running 50622. Please use mysql_upgrade to fix this error.
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_waits_summary_by_host_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Incorrect definition of table performance_schema.events_waits_summary_by_thread_by_event_name: expected column ‘THREAD_ID’ at position 0 to have type bigint(20), found type int(11).
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_waits_summary_by_user_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_waits_summary_by_account_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Column count of mysql.file_summary_by_event_name is wrong. Expected 23, found 5. Created with MySQL 50540, now running 50622. Please use mysql_upgrade to fix this error.
    2015-01-09 15:59:14 16398 [ERROR] Column count of mysql.file_summary_by_instance is wrong. Expected 25, found 6. Created with MySQL 50540, now running 50622. Please use mysql_upgrade to fix this error.
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘host_cache’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Incorrect definition of table performance_schema.mutex_instances: expected column ‘LOCKED_BY_THREAD_ID’ at position 2 to have type bigint(20), found type int(11).
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘objects_summary_global_by_type’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Incorrect definition of table performance_schema.rwlock_instances: expected column ‘WRITE_LOCKED_BY_THREAD_ID’ at position 2 to have type bigint(20), found type int(11).
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘setup_actors’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘setup_objects’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘table_io_waits_summary_by_index_usage’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘table_io_waits_summary_by_table’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘table_lock_waits_summary_by_table’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Column count of mysql.threads is wrong. Expected 14, found 3. Created with MySQL 50540, now running 50622. Please use mysql_upgrade to fix this error.
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_current’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_history’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_history_long’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_summary_by_thread_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_summary_by_account_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_summary_by_user_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_summary_by_host_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_stages_summary_global_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_current’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_history’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_history_long’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_summary_by_thread_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_summary_by_account_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_summary_by_user_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_summary_by_host_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_summary_global_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘events_statements_summary_by_digest’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘users’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘accounts’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘hosts’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘socket_instances’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘socket_summary_by_instance’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘socket_summary_by_event_name’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘session_connect_attrs’ has the wrong structure
    2015-01-09 15:59:14 16398 [ERROR] Native table ‘performance_schema’.‘session_account_connect_attrs’ has the wrong structure
    2015-01-09 15:59:14 16398 [Note] Event Scheduler: Loaded 0 events
    2015-01-09 15:59:14 16398 [Note] /usr/sbin/mysqld: ready for connections.
    Version: ‘5.6.22’ socket: ‘/var/run/mysqld/mysqld.sock’ port: 3306 MySQL Community Server (GPL)[/CODE]

    1. Image
      [IMG]http://i60.tinypic.com/2mg1bnd.png[/IMG]

    2. [url]https://www.dropbox.com/s/vgycit4pac2r0at/apacheerror.log?dl=0[/url]

    Thanks for the help.

    It appreas to be a mysql login error.

    I upgraded from 5.5 to 5.6 to see if i could solve the problem.


  • Developer

    [LIST=1]
    []When fog installed did you use a password for the database?
    [
    ]Can you login to the database using username root? --> mysql -u root fog
    []If yes to question 1, can you login to the database using --> mysql -u root -p <password you entered> fog
    [
    ]Do you have any errors in your mysql log?
    []Are there any errors on your screen when trying to login to the database?
    [
    ]What does show up when you go to your fog server URL? (picture required)
    [*]Can you give use your apache error log file? (file upload required)
    [/LIST]
    Pictures and/or video work wonders!



  • got the sql issue sroted now i am running 5.6 now on debian.

    but its still the same issue, The database update page doesnt appear.



  • debian


  • Developer

    what OS are you running?



  • [quote=“Tom Elliott, post: 40534, member: 7271”]You’re using MSSQL and not MySQL?[/quote]

    a typo on my behalf. I am used to windows world.:D

    the mysql errors started after a system update.

    what version of myssql does fog use, can i upgrade to 5.6?


  • Senior Developer

    You’re using MSSQL and not MySQL?



  • no joy.

    oddly with the mssql not starting the database schema update page now appears when i log into fog.

    pure madness about to start from scratch here to be honest.


Log in to reply
 

479
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.