Internet in VM fog



  • Hi
    I have a laptop with the same FOGSVR VBOX as my desktop. Copied same machine etc. On the desktop FOG DHCP is [B]not[/B] set up in FOG as I have a [B]DDWRT router[/B] which takes care of that. Works great. However on the laptop I have to have DHCP enabled in the box because I image client machines ethernet to ethernet via a cross over cable. Master system on the desktop, replicated on the laptop for “portability”. Works great.

    So. I need to copy /images from desktop to laptop /images. In the laptop I can interface fine with the fog GUI. But I cannot get the internet to work for love nor money. Have stopped the DHCP server, renewed IP address, switched VBOX adaptor settings, all sorts. My thinking is with the DHCP stopped the laptop is identical to the desktop due to cloning nature, so should get the internet etc which works fine for LAN / WAN.

    Im sure I’m missing the obvious but need it pointing out. Thanks for any help.


  • Developer

    Since it’s a VM, take a snapshot. Then issue the dnsmasq removal command:

    sudo apt-get remove dnsmasq
    

    See if you can Ping internally, if so test the internet. Reboot the VM, turn off your dhcp service again and see if internet is still available. If any of this breaks your ability to connect to the network, then you need to restore your snapshot and disable both the dhcp and dnsmasq services on boot when you need to connect to your home network.


  • Developer

    That’s a tough one. see in Ubuntu 12.04.4 and 12.04.5 and 14.04 and 14.10 they started including dnsmasq-base as a service and requiring it for network-manager. you can issue a command to remove the dnsmasq service, but it’s likely to break your entire ability to connect to a network, which makes it really hard to install services to fix your issues. I would issue the dnsmasq stop command when you are at home and leave the service installed.



  • thats deffo fixed it - can it be removed or disbaled? thanks



  • Panic over forgot i’d tried using dnsmasq on the fog laptop - stopped the service and worked fine - sorry LOL

    service dnsmasq stop


  • Senior Developer

    Also,

    Seeing as your laptop, I presume, is running linux, have you checked your /etc/resolv.conf file to ensure it actually is getting a nameserver to look at? Can you access the internet via IP Addresses?


  • Developer

    When you say internet, you actually mean to World wide Web? or are you unable to connect to your home network?

    I don’t see why not having internet to copy the file from one computer to another would cause you any grief.



  • Thanks guys - sorry missed info - ubuntu 14.04.01 and fog trunk 2815.

    Desktop set up and working fine installed using one of the guides available. followed defaults (static IP 192.168.1.99) and just said no to DCHP as DDWRT to take care of that. So when I have a client machine at home I can boot off the lan, quick image, jobs a good 'un.
    So I thought that when I am out and about doing visit’s, be a shame to leave all that imaging work and capability at home, so copied the machine (VM) to vbox install on my laptop. That way can still image using fog via ethernet to ethernet.

    Of course for that I need to have the FOG DHCP working so re ran the installer and set up defaults static IP same as in eth0 etc BUT enabled DHCP so machines hanging off the back of the laptop will get IP and work etc. Thats the reason for that :-)

    So have tried this command to stop DHCP, yes, because different linux flavour the command was different. This one actually Stops the service (or says it has) where as others leave it in waiting status.

    [I]sudo /etc/init.d/isc-dhcp-server stop [/I]

    Then I created a new connection that uses DHCP instead of the static entry fog requires and made sure the connection was “bridged” between VBOX & my laptop ethernet while connected and also the wireless. I thought that should do the job but no cigar. Have released and renewed. Fiddled around tried NAT etc. I thought disabling DHCP would give me internet then enabling give me back fog.

    The ip adress in the connection is concurrent (192.168.1.94) with the router giving the IP and not FOG (10.0.2.2 etc) Thanks


  • Senior Developer

    I guess I’m confused why you’re imaging directly from cross over cable when you already have a router/switch capable of passing the data.


  • Developer

    If I were you, I would disable the dhcp server when I want to connect to my home network.

    It sounds to me, your issues are stemming from two DHCP servers in the network and the laptop doesn’t have the correct nameserver entries for your network.

    How are you setting your static IP address? What Linux OS have you installed fog on?

    Sorry I read that you stopped the service but it didn’t solve the issue, have you used the resolvconf solutions yet?


Log in to reply
 

523
Online

38916
Users

10685
Topics

101347
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.