Fog Svn 2784 Master image, multiple partition upload error/image registration error



  • Hey all,

    After listening to some previous advice I have recently installed the svn fog version to help with partition uploads.
    Installed fine in a ubuntu virtual box enviroment.
    Fog version: 2784
    Image:
    Windows 7
    Multiple partitions, single harddisk, no resizable.
    Error when trying to image registration.
    [CODE]Starting logging:ok
    Populating /dev using dev : error creating poll fd: function not implemented
    Done
    Initialising random number generator done
    starting network
    ssh-keygen
    starting sshd:ok
    /bin/fog.man.reg: /usr/share/fog/lib/funcs.sh: line 28: syntax error: bad for loop variable
    Reboot: starting system.
    [/CODE]

    Thanks in advance.

    UPDATE: I just ran “cd /usr/share” to discover there is no fog folder. Not sure why it wasn’t created on install?


  • Developer

    did you try changing the linux password for the user “fog” and setting the storage ftp password to the same?



  • update: when I ask a host to upload a master image I get this error which may be explaining why the ftp server isn’t working.
    Populating /dev using udev: udevd[2278] error creating poll fd: function not implemented.

    As the images are still being stored in /dev rather than /images.


  • Developer

    that’s not what the fog linux user password is. you’ll likely need to change the linux password, and then put that new password in the storage ftp settings location



  • I have left the fog u/n and p/w to the defaults of fog/password so I’ll try that.


  • Developer

    yes there should be a password set, try updating the password to that of the FOG user, save settings and try again.

    you can also use a ssh terminal such as putty to ftp into the fog server, if you can create folders in the command line using putty, your fog server should be able to move images without intervention.



  • There currently is no password entered in fog-sftp-ftp-password. should there be a default one? tftp-host is the same ip as the fog server itself we i presume is also correct.
    Apologies, i didn’t realise the ftp was how fog moved the folders.
    Thank you!


  • Developer

    [quote=“Chris Shanks, post: 39909, member: 27169”]Update: I think it is the image creation process as when I create a new image and save to default storage node (/images) it does not create a subdirectory for the upload to save in causing the previously posted error. Is this just my sql or the svn?
    If it is just me, would you be able to help solve the problem please?
    Thanks

    Info:
    in fog settings.
    fog storage nod is: fogstorage
    fog storage node pass: random password that i presume sql created, should this be the defined one I entered during installation?[/quote]

    This is neither sql or the svn, it is your FTP settings. FTP is how fog moves the folder from /images/dev/macaddress to /images/imagename.

    Please verify that your FTP username and password are correct in the settings.

    you can manually create the folder and move the content in from /images/dev/macaddress, this would solve the issue until you can fix your FTP problems.



  • Update: I think it is the image creation process as when I create a new image and save to default storage node (/images) it does not create a subdirectory for the upload to save in causing the previously posted error. Is this just my sql or the svn?
    If it is just me, would you be able to help solve the problem please?
    Thanks

    Info:
    in fog settings.
    fog storage nod is: fogstorage
    fog storage node pass: random password that i presume sql created, should this be the defined one I entered during installation?



  • I can confirm that latest svn work fine.



  • @Tom Elliott
    Another problem that might just be me but hoped i could run it past you.
    The upload master image and registrations works fine however I am now having problems with the mysql and image location. On install i left the storage node as default /images, pulled an image like I would usually however it is not creating the folder in /images and appears not to be pulling correctly as the image info shows size on client as 5.00GiB and size on server as 0.00GiB.
    The only thing in the /images folder is /dev and /postdownloadscript. Hope this helps.

    I have tried the install with both leaving the root mysql password blank for all instructions and creating a password and entering it on request as well.



  • Cool, i’ll test right now. Don’t be sorry as we know what can happend if using svn :)



  • No apology needed! I wouldn’t have a clue about half the functions that fog does on the back end.


  • Senior Developer

    Alright,

    Both init’s should work properly now.

    Sorry about the mess up.


  • Senior Developer

    init’s are still a little wonky.

    Working on it right now.



  • Cpasjuste, I had the problem with clamav, I just cd’d into the directory and created the folder myself, solved the problem.


  • Senior Developer

    I’m in the works of moving how clamav is done. I swore I commented out the freshclam installer piece last night, but it looks like it didn’t hold.

    It should be fixed for in 2787.

    Still building the 32 bit init, but the 64 bit should be good to go.



  • I ran the cd usr/share on the ubuntu based server. Client is windows so presumably wouldn’t have the same file structure however on inspection of our old working “non svn” fog server, it doesn’t have the fog folder within /share either so not sure there.
    I somewhat understand, not exactly sure about how sh and bash interact, will go and do some reading whilst you fix the problem.
    I presume when fixed, a new checkout pull from svn will be needed?



  • Hi, i do have the same problem with svn 2785. I also have this error on installing now :
    [CODE] * Configuring Fresh Clam…cp: impossible d’évaluer «…/packages/clamav»: Aucun fichier ou dossier de ce type
    chmod: impossible d’accéder à «/opt/fog/clamav»: Aucun fichier ou dossier de ce type
    Failed!
    [/CODE]


  • Senior Developer

    You ran:

    cd /usr/share on the client or your fog server? They’re two separate things.

    I’m already working to fix the problem. I updated the init’s to 2014.11 last night. Apparently there was a change where the #!/bin/sh is not redirected to bash anymore. This is why you’re seeing the issue. Nothing changed, from a scripting standpoint, that caused this, simply the way sh and bash operate has changed which was unexpected. I’m sorry about the confusion.

    I’ll let you know when all is up. The 64 bit should be ready for re-download should you need it.


Log in to reply
 

348
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.