[SOLVED] No internet connection after setting static ip in Ubuntu

  • Developer

    This includes but is not limited to:
    Ubuntu 12.04.4, 12.04.5, 14.04, 14.10

    If you set a static ip address by editing /etc/network/interfaces and you do not have an internet connection after rebooting, or restarting the service, you need to supply your dns server in your resolv.conf file.

    To do so: (wiki article) [url]http://fogproject.org/wiki/index.php/Ubuntu_14.04#Setting_static_IP[/url]

    open terminal and issue the following command:
    sudo nano /etc/resolvconf/resolv.conf.d/head[/code]

    Ignore the warnings about settings being over written, this is the “Head” of the resolve conf file and anything in this file will be carried down to resolv.conf when it is generated. This warning is meant to be displayed in resolv.conf warning users that changes will be over written. We are supplying the name server manually to the resolve.conf file by letting the head file carry the information for us.

    Add the following line where x.x.x.x is the ip address of your DNS. If you need to supply multiple DNS entries, separate entries with a space (i.e. nameserver x.x.x.x y.y.y.y z.z.z.z)
    nameserver x.x.x.x[/code]

  • Banned

    This post is deleted!
  • Banned

    This post is deleted!

  • BOOM! That did it. Awesome! Thanks so much. I really appreciate your assistance with all this. My next step is to attempt to mount my windows share through the VM. Learning as I go!