Fog 2734: Can't update Active Directory settings



  • If I go to a host’s (or group’s) Active Directory settings, check the “Add to Active Directory” box to autofill the options, and click “Update,” I get taken to a blank screen and the update does not occur. The page has no body that I can see in Chrome’s Inspect Element.

    This also happens when clicking, “Save Changes” in the FOG Configuration page.



  • After a bunch of research I was able to solve my issue. For some reason mcrypt only had it’s mcrypt.ini file in the /etc/php5/conf.d folder. The file also needs to be in the /etc/php5/apache2/conf.d and /etc/php5/cli/conf.d folders. I simply copied the file to those 2 directories and restarted apache and then the active directory options worked again. If anybody else in ubuntu has this problem check those directories for the mcrypt.ini file.



  • I’m also getting this issue with almost the exact apache error except mine references line 272. I tried the update you suggested but I’m given the message that I already have the latest version of mcrypt. I’m currently on SVN 2873


  • Senior Developer

    @2cool4me4, post: 39606, member: 25120 said:

    I’ll be darned. That took care of it.

    As a person once said to me: “Tom, you have no idea what you’re doing.”



  • I’ll be darned. That took care of it.


  • Senior Developer

    Can you try installing mcrypt with apt-get install php5-mcrypt



  • http://10.1$

    To be exact


  • Senior Developer

    What’s in you Apache error logs when you get the white page?


Log in to reply
 

394
Online

38713
Users

10542
Topics

99804
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.